Page MenuHomePhabricator

Langlink box has scrollbar in Firefox
Closed, InvalidPublic

Description

Steps to reproduce:

  1. Use Firefox.
  2. Visit any article with links to other languages.

Expected:
The box with langlinks should not have a scrollbar.

Actual:

Details

Related Gerrit Patches:

Event Timeline

Schnark created this task.Nov 28 2017, 11:18 AM
Izno added a subscriber: Izno.Nov 28 2017, 2:24 PM

Do you have ULS-CompactLinks enabled? It doesn't look like it, but I am going to ask the dumb question.

Do you have ULS-CompactLinks enabled? It doesn't look like it, but I am going to ask the dumb question.

I have (the example above just had too few links to let it kick in), but disabling it doesn't change anything.
As the scrollbar doesn't appear on the main page or on user pages like https://en.wikipedia.org/wiki/User:Beetstra I suspect the "Edit links" link added by Wikidata Client to be just 1px (or something like that) too high.

Change 441749 had a related patch set uploaded (by Jack Phoenix; owner: Jack Phoenix):
[mediawiki/skins/Timeless@master] Language links box should not have an unnecessary scrollbar

https://gerrit.wikimedia.org/r/441749

I can't reproduce this using Firefox 61.0 on Windows 10.

Perhaps it was a browser bug and it is fixed now?

I can still reproduce this in Firefox ESR 60 on Linux, and can confirm that the proposed patch fixes this.
The overflow: auto actually is with the grandparent #mw-related-navigation .sidebar-chunk.

ashley added a subscriber: ashley.Jul 9 2018, 12:32 AM

I can't reproduce this using Firefox 61.0 on Windows 10.
Perhaps it was a browser bug and it is fixed now?

Seems like that -- it certainly was reproducible and fixable when I wrote the patch, but now I also can't reproduce it with Firefox 61.0 on Ubuntu 18.04.

Isarra closed this task as Invalid.Aug 30 2018, 2:27 AM
Isarra added a subscriber: Isarra.

Seems to no longer be an issue regardless.

Change 441749 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Language links box should not have an unnecessary scrollbar

https://gerrit.wikimedia.org/r/441749