Page MenuHomePhabricator

Update Wikimedia configuration to prevent some users from sending emails
Closed, ResolvedPublic

Description

Now that T178842 is merged, we need to update the Wikimedia configuration to limit who can send emails to:

Users in the groups bureaucrat, steward, wmf-supportsafety, and global-renamer should still have the ability to send email to these users.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 10 2017, 10:08 PM
Legoktm renamed this task from Update WMF Configuration to Prevent Some Users from Sending Emails to Update Wikimedia Configuration to Prevent Some Users from Sending Emails.Dec 10 2017, 10:28 PM
Legoktm updated the task description. (Show Details)

Change 397768 had a related patch set uploaded (by EddieGP; owner: EddieGP):
[operations/mediawiki-config@master] Restrict sending mails to new users

https://gerrit.wikimedia.org/r/397768

Framawiki renamed this task from Update Wikimedia Configuration to Prevent Some Users from Sending Emails to Update Wikimedia configuration to prevent some users from sending emails.Dec 12 2017, 9:24 PM
Framawiki added a subscriber: Framawiki.
EddieGP claimed this task.Dec 13 2017, 8:41 AM

To deploy this in SWAT, the patch will need a review from someone of SuSa.

The patch looks good from SuSa's side. We'll also want to add it to a couple global groups but I've verified it's available and we do that on-wiki so I'll send a note to the Stewards to do that side.

jrbs moved this task from Backlog to Other team on the Trust-and-Safety board.

Hi @EddieGP — Now that we have the review and OK from @Jalexander, can we get this released by the end of the calendar year?

Hey @TBolliger - unfortunately not, as there is a deployment freeze for this and next week because of the holidays (so that errors during christmas/new year are less likely and thus the probability that ops have to work on fixing said errors during their holidays shrinks).
Normal deployments resume Jan 2nd. I've already scheduled the patch for Jan 4th, because I know I'll be around that day; if I manage to be online on the 2nd, we might as well push it out then, but I can't guarantee that.

OK, thank you!

Change 397768 merged by jenkins-bot:
[operations/mediawiki-config@master] Restrict sending mails to new users

https://gerrit.wikimedia.org/r/397768

Mentioned in SAL (#wikimedia-operations) [2018-01-04T14:11:43Z] <niharika29@tin> Synchronized wmf-config/InitialiseSettings.php: Restrict sending mails to new users T182541 (duration: 01m 02s)

EddieGP closed this task as Resolved.Jan 4 2018, 2:16 PM

This is now live. I've verified it working by opening https://test.wikipedia.org/w/index.php?title=Special%3AEmailUser&target=<user name of some autocreated but never used account>. Before swat, it loaded the form to mail the user, now it says "This user has chosen not to receive email from other users." I can't test whether this still works for the bureaucrat, steward, wmf-supportsafety and global-renamer groups though, that has to be checked by a member of these groups.

The message "This user has chosen not to receive email from other users" should be changed as it's very misleading. Perhaps something like "This user cannot receive e-mail from other users". Is this displayed through MediaWiki extension?

JJMC89 added a subscriber: JJMC89.Jan 4 2018, 6:14 PM

Communities should have been notified before deploying this.

Some contact role accounts are not able to receive emails until someone with credentials makes a dummy edit with the account. Accounts for oversight, OTRS, and ArbCom are impacted at English Wikipedia.

SPoore added a subscriber: SPoore.Jan 4 2018, 6:32 PM

Hi JJMC89,

It was planned that accounts without edits should be able to receive email on their home wiki. If that is not happening, then something is wrong that needs to be fixed.

That should fix it for role accounts, right?

JJMC89 added a comment.Jan 4 2018, 6:47 PM

It was planned that accounts without edits should be able to receive email on their home wiki. If that is not happening, then something is wrong that needs to be fixed.
That should fix it for role accounts, right?

That is not what is happening (personally tested for User:Oversight, User:Arbitration Committee, and User:Wikipedia Information Team before they edited). If fixed it would allow email in some cases.

User:Oversight's home wiki is not English Wikipedia and it has unattached accounts, so I'm not sure it would have been able to receive email after a fix if it had it not just edited.

@JJMC89 — Making a dummy edit opens up the ability to be emailed, and you won't have to worry about it again.

The 1.31.0-wmf.15 rollout has hit meta but not yet English Wikipedia. It should complete by end of day today. This makes testing cross-wiki features on production tricky.

jrbs added a subscriber: jrbs.Jan 4 2018, 6:57 PM

@JJMC89 — Making a dummy edit opens up the ability to be emailed, and you won't have to worry about it again.
The 1.31.0-wmf.15 rollout has hit meta but not yet English Wikipedia. It should complete by end of day today. This makes testing cross-wiki features on production tricky.

(You already saw, but just to note here: I just created a subtask to track this.)

JJMC89 added a comment.Jan 4 2018, 7:06 PM

@JJMC89 — Making a dummy edit opens up the ability to be emailed, and you won't have to worry about it again.

I'm aware of that. Getting those with access to the role accounts to make an edit can take time, which is why the communities should have been notified prior to deployment.

The 1.31.0-wmf.15 rollout has hit meta but not yet English Wikipedia. It should complete by end of day today. This makes testing cross-wiki features on production tricky.

If that impacts this then https://gerrit.wikimedia.org/r/397768 shouldn't have been deployed until after the 1.31.0-wmf.15 rollout was complete.

I've added the new right to the stewards global group, because in the local group it only works on Meta. This is an issue for global renamers, as they don't have a global group. As it stands, they will only be able to send emails from Meta. (or where the user a) has an account with edits and b) has enabled receiving emails)

Is there any way of fixing this, without needing to create a global group for the renamers?

Risker added a subscriber: Risker.Jan 4 2018, 10:20 PM

The solution solved a problem that wasn't really the problem. The issue was bots generating email messages to users who simply read a page. The solution was to give the users a global option to determine which wikis they wished to receive bot email messages from - or alternately to prevent bots from sending emails. (There is no evidence at all that bot email messages ever bring users to wikis.)

This did create problems on enwiki, and we aren't the only project that has non-editing role accounts.

DoRD added a subscriber: DoRD.Jan 4 2018, 10:33 PM

I've added the new right to the stewards global group, because in the local group it only works on Meta. This is an issue for global renamers, as they don't have a global group. As it stands, they will only be able to send emails from Meta. (or where the user a) has an account with edits and b) has enabled receiving emails)
Is there any way of fixing this, without needing to create a global group for the renamers?

I've created T184294: Global renamers should be able to email any emailconfirmed user on any wiki to track this. @SPoore — Let's reach out to https://meta.wikimedia.org/wiki/Global_renamers