Page MenuHomePhabricator

Deploy PageAssessments to Arabic Wikipedia
Closed, ResolvedPublic5 Story Points

Description

Their system seems similar to enwiki's, with assessment scales, importance ratings, and WikiProjects.

Example talk page: https://ar.wikipedia.org/wiki/نقاش:بغداد (featured article)

Meta template: https://ar.wikipedia.org/wiki/قالب:شريط_مشروع_ويكي_ورائي

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 16 2018, 7:07 PM
Restricted Application added a subscriber: alanajjar. · View Herald TranscriptFeb 6 2018, 10:09 PM
Niharika set the point value for this task to 5.Feb 7 2018, 12:15 AM
Meno25 added a subscriber: Meno25.Feb 7 2018, 4:37 PM
Meno25 added a subscriber: FShbib.Feb 7 2018, 4:47 PM
MusikAnimal added a comment.EditedMar 2 2018, 6:47 PM

@Meno25 @FShbib We'd like to get started on this soon. First I'll give some background, so you know why we want to do this:

What is Page Assessments?

Page Assessments is a MediaWiki extension for storing article assessments (e.g. WikiProjects) in a structured and machine-readable way. This means tools, scripts, gadgets, etc., can use this data to show assessment data. For example, XTools Pages Created shows assessments of all the articles created by a user, and XTools Page History shows assessments of an article for each individual WikiProject. Other tools like Pageviews Analysis also show article classifications.

After deployment, if your wiki is interested, we could also set up Popular pages bot. With this, you can configure it so that every month, the bot will give the most-viewed pages for a given WikiProject. This can help identify what pages need more attention from editors.

You will also have a Special:PageAssessments page to browse all articles and their assessments. We'll make sure this is localized.

How to install

We will handle deploying the extension itself, but we definitely need help updating the templates :)

To make it work, you use the parser function {{#assessment: <name of the wikiproject> | <class> | <importance>}}. This will go in your WikiProject meta template, which appears to be قالب:شريط_مشروع_ويكي_ورائي. So for example, if you have the parameters |wikiproject=, |class= and |importance=, then the syntax would be something like {{#assessment:{{{wikiproject|}}}|{{{class|}}}|{{{importance|}}}}}. This code won't actually render anything, it just tells the extension to store the data you pass to it.

More documentation on usage is at mw:Extension:PageAssessments#Usage.

MusikAnimal added a comment.EditedMar 20 2018, 9:46 PM

@Menu25 sorry to ping you again, any interest in bringing this to Arabic Wikipedia?

I double-checked your meta template, and I'm confident it will work. We just of course need endorsement from your community :)

@MusikAnimal
If @Meno25 not free, please ping me and I'll open a request on ar.wiki (discussion/voting request), to give you the community endorsement.

I think it should be stalled until that?

@MusikAnimal
If @Meno25 not free, please ping me and I'll open a request on ar.wiki (discussion/voting request), to give you the community endorsement.

That'd be great :) No need to wait for Meno, they can chime in on the discussion.

You can use the description at T185023#4018825 as the proposal. Note that I've already confirmed your meta template is compatible, so all we need is community support. And again, the #assessment parser function does not render anything, so there will be no visual change. It just adds the assessments to a database.

Once your community has given the OK, we will deploy the extension, and then ask you to update قالب:شريط_مشروع_ويكي_ورائي.

Thanks!

@MusikAnimal

It's Done (see here)

We should wait now.

alanajjar triaged this task as Normal priority.Mar 21 2018, 4:33 PM

Thank you @MusikAnimal for your initiative. I am glad that we can deploy this extension to Arabic Wikipedia. I modified the Meta template and it's sub-templates to be compatible with Arabic, and I can help with any further changes you need.

Thank you @alanajjar for starting the discussion.

Excellent! Arwiki's assessment system seems very similar to enwiki, so I don't anticipate any problems.

Once the extension is deployed, I'll reach out to you @FShbib about adding the parser function. Are you on IRC? Ideally we'd be online at the same time so that we can monitor database activity.

MusikAnimal edited projects, added Community-Tech-Sprint; removed Community-Tech.
MusikAnimal moved this task from Ready to In Development on the Community-Tech-Sprint board.

@MusikAnimal

Of course. Please ping me when you are finished. Thank you.

@FShbib Before we deploy the extension, I want to ask you about your meta template. On English Wikipedia, the meta template uses a "masking" template that makes sure article classifications are valid. For instance, class=cheesecake is invalid (the only valid classes are FA, GA, A, B, C, etc.). In your case I believe the classifications are called الصنف, with values like م.مخ.

Do you have such a template? If not, it might be a good idea to implement one before we add Page Assessments. We don't have to, it is just a means to ensure the data is valid.

FShbib added a comment.Apr 6 2018, 9:26 PM

Hi @MusikAnimal.

Yes, we do use a masking template to do so, and you are correct, we use الصنف for class and الأهمية for importance.

Change 424709 had a related patch set uploaded (by MusikAnimal; owner: MusikAnimal):
[operations/mediawiki-config@master] Enable PageAssessments on arwiki

https://gerrit.wikimedia.org/r/424709

Yes, we do use a masking template

Wonderful :) I have created the patch to deploy the extension, then I'll get back to you about updating the template.

@MusikAnimal Remember to get the tables created by the deployer.

Change 424709 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable PageAssessments on arwiki

https://gerrit.wikimedia.org/r/424709

Mentioned in SAL (#wikimedia-operations) [2018-04-09T18:58:39Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Enable PageAssessments on arwiki (T185023) (duration: 01m 00s)

MusikAnimal added a comment.EditedApr 9 2018, 7:32 PM

@FShbib We are ready to go! The special page is now live: https://ar.wikipedia.org/wiki/خاص:PageAssessments

There are a few issues around translations that we will have to fix. I see everything on translatewiki has been translated to Arabic, yet:

  • The "Page Assessments" title is either untranslatable or the message isn't being used
  • The "Search" button text apparently isn't using the i18n message

I'll work on that, but please feel free to proceed for now.


Once you add the parser function to the template, the new Special page should slowly populate with the assessments for all the articles.

Ideally, I'd be around to monitor database activity when you add the parser function, but we just did this for Turkish Wikipedia, and nothing went wrong. I suspect nothing will go wrong here, either. I'm on IRC as musikanimal if you want to ping me.

You know how the templates work... I'm not sure exactly what code needs to be added, but *think* it will be something like:

{{#assessment:{{{المشروع}}}|{{#ifeq:{{{الصنف|¬}}}|¬||{{{الصنف}}}}}|{{#ifeq:{{{الأهمية|¬}}}|¬||{{{الأهمية}}}}}}}

That's assuming that at this point, the masking templates have already been used to normalize the values.

This code should also be wrapped in <includeonly> so that it isn't doesn't get used when the template is substituted.

  • The "Page Assessments" title is either untranslatable or the message isn't being used
  • The "Search" button text apparently isn't using the i18n message

Grrr, it apparently is because the translations haven't been reviewed https://translatewiki.net/w/i.php?title=Special:Translate&filter=translated%7C%21reviewer%3A19682%7C%21last-translator%3A19682&group=ext-pageassessments&language=ar&action=proofread. I have no authority to do that, but I will try to poke some people... (if you're a translator there, of course feel free to take charge!)

FShbib added a comment.EditedApr 9 2018, 11:12 PM

Thank you very much @MusikAnimal I really appreciate your initiative to bring this extension to Arabic Wikipedia.

Everything is great, and articles starts showing on the special page, and I reviewed all remaining translations and corrected others.

Now, what other tools we could use beside Popular pages bot? I see great potential in this extension, and we want to get the best out of it ^_*.

Thank you very much @MusikAnimal I really appreciate your initiative to bring this extension to Arabic Wikipedia.

My pleasure, I'm glad to hear you all are excited about it!

Everything is great, and articles starts showing on the special page, and I reviewed all remaining translations and corrected others.

Fantastic! All looks good on my end, too. No database issues.

Now, what other tools we could use beside Popular pages bot?

XTools and Pageviews Analysis will both start showing assessments soon, once I get them updated.

The assessment data will be available on the page_assessments table on the replicas, so you could create any tool to utilize the data however you want. For instance, you could use Quarry to run a query that shows the featured articles that are in a specific category. A more specific example is say, if you have an editathon coming up, and you want people to work on improving low-rated articles that are about female entertainers. With Page Assessments, you could create a worklist so people know which articles to work on.

The data is also available in the PageAssessments API. One cool thing you could do with this is create a gadget that shows the article assessment when you browse to the article. An example of how this could look would be the Metadata gadget on English Wikipedia (internally, it doesn't actually use Page Assessments because it is a very old gadget, but you could do the same thing with Page Assessments).

Hi, I checked the database and there are assessments for 123,113 articles. This is great, but only a fraction of your 556,221 articles.

For instance, the selected article for April 10, 2018, is إينياتسيو سيلونه. This is on the Main Page (الصفحة الرئيسية). Yet surprisingly, it has not been given any WikiProjects and so it is not in page assessments, see نقاش:إينياتسيو سيلونه.

I know you both sometimes use the ويكيبيديا:المقيم script to add WikiProject assessments. Maybe the process could change so that before an article is put on the Main Page, it is given WikiProjects? It is just odd that the Main Page article has been "selected", but in the database it has not been selected.

Just a recommendation! :)

MusikAnimal closed this task as Resolved.Apr 10 2018, 4:01 PM
MusikAnimal moved this task from Ready to Done on the MediaWiki-extensions-PageAssessments board.
MusikAnimal moved this task from Engineering backlog to Archive on the Community-Tech board.

Thanks all, especially @MusikAnimal

My pleasure! XTools nows shows assessments, e.g. https://xtools.wmflabs.org/articleinfo/ar.wikipedia.org/القدس and https://xtools.wmflabs.org/pages/ar.wikipedia.org/FShbib

I'll add it to Pageviews Analysis soon, and will also notify maintainers of the WikiEd Dashboard that this feature is now available (ping @Ragesoss ! Also available, Turskish Wikipedia: T184969)

By the way, while the PageAssessments API gives you the WikiProject and assessment, it does not give you the associated color and icon (requested at T156828). So for the time being, I've added this to the the XTools API. See the documentation to get assessments for specific articles, and the overall Page Assessments configuration.

Thank you @MusikAnimal. Your recommendations have been taken into account :).

We started using Page Assessments before one year, and we have a few Wikiprojects that are active and have editors to maintain articles and assess them. Wikiproject Medicine and Wikiproject Film are great examples of how Arabic Wikipedia could benefit from organized collaborations, and many other wikiprojects are starting to get active again.

Last question and I'm sorry for taking too much of your time, How could we set up Popular pages bot on Arabic Wikipedia?

@MusikAnimal

It seems that Pageviews Analysis does not show any results when the page has an assessment (Example), is that a problem or it's normal until you update it?

Last question and I'm sorry for taking too much of your time, How could we set up Popular pages bot on Arabic Wikipedia?

I have created T191999. Arabic will be the first project other than enwiki to use Popular Pages Bot, so most of the work for us is making the bot translatable. We may seek your help with that.

But first, we need consensus and bot approval. Note WikiProjects are manually added to the bot via an on-wiki config page (e.g. see Popular pages config.json on enwiki). Would mind asking a few WikiProjects if they are interested? After the bot is up and running, you will be able to add new WikiProjects yourself without our help, but we need a few to start with.

It seems that Pageviews Analysis does not show any results when the page has an assessment

Yep, I still need to update that tool. I'm first reworking some of the code in XTools, so that Pageviews Analysis can use the XTools API. That way all the assessment-related code is in one place. I expect to have this done in the coming days.

I have created T191999. Arabic will be the first project other than enwiki to use Popular Pages Bot

That's great. I will reply there.

Yep, I still need to update that tool.

No problem, take your time and thanks in advance :).

Pageviews Analysis is now showing assessments, e.g. https://tools.wmflabs.org/pageviews/?project=ar.wikipedia.org&pages=بيتر_دينكلاج

XTools as well: https://xtools.wmflabs.org/articleinfo/ar.wikipedia.org/بيتر_دينكلاج#assessments

We are working on getting Popular Pages Bot to have better cross-wiki support, and arwiki is first in line. More at T191999