Page MenuHomePhabricator

replace tin (new hardware)
Closed, ResolvedPublic

Description

replace tin.eqiad.wmnet (deployment_server) with new hardware and a fresh OS install, using a new server name,

because the hardware is out of warranty.

hardware request has been opened in T184481

this is part of the hardware refresh goal

Event Timeline

Dzahn created this task.Jan 18 2018, 11:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 18 2018, 11:38 PM

done! this was a duplicate of

T175288 (see all the details for this there)

T184481

Dzahn closed this task as Resolved.Mar 27 2018, 10:52 PM

It has been replaced by deploy1001.eqiad.wmnet on stretch with PHP7.

A summary of things as I understand them:

  • deploy1001 to php7 is needed for git-lfs, which is needed for ORES.
  • icu collation order with libicu57 (default with php7) is different than with libicu52 (what we have everywhere with php5 and hhvm).
  • The possibility of some maintenance script (which folks generally invoke with foreachwiki) running on deploy1001 and updating anything in the dbs that relies on collation order, would be a problem until icu migration on Apr 9.
  • foreachwiki relies on foreachwikiindblist which right now needs php5 and I guess should need hhvm but hey, that's maybe never been tested (really? ouch). So it's broken there for now, which is good because of the above. But...
  • l10nupdate on the deployment host relies on a working foreachwiki, one way or anther. It by itself doesn't cause any db writes, just rebuilds of the cdb files and cleanup of some cache keys.

In the meantime we are back to tin.

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-04-11T18:11:47Z] <mutante> deploy1001 is back on stretch once again - it has been removed from scap hosts though (T175288 T185275)

Dzahn triaged this task as High priority.May 2 2018, 8:17 PM
Dzahn changed the status of subtask T196175: decom/reclaim tin from Open to Stalled.
Dzahn added a comment.EditedJun 1 2018, 5:14 PM

It has switched from tin to deploy1001 (again, this time hopefully for good) today. All the details were in T175288.

Just some more cleanup here for tin maybe.

A decom task for tin will be T196175.

Dzahn added a comment.Jun 7 2018, 2:08 PM

tin has been replaced. deploy1001 is active since a couple days and tin is now using role spare::system since today and has been removed from network constants and other places:

https://gerrit.wikimedia.org/r/#/c/420917/

Dzahn closed this task as Resolved.Jun 7 2018, 2:09 PM
Dzahn changed the status of subtask T196175: decom/reclaim tin from Stalled to Open.

Change 438028 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] deployment::server: require libwww-perl

https://gerrit.wikimedia.org/r/438028

Change 438028 merged by Dzahn:
[operations/puppet@production] deployment::server: require libwww-perl

https://gerrit.wikimedia.org/r/438028