Page MenuHomePhabricator

[BUG] Some content is not rendering correctly in the Quick box / Info box on Android web view
Closed, ResolvedPublic

Description

Certain content in the info box is getting cut off, appears to be whenever a media player is in an info box on Android.
First reported via OTRS: https://ticket.wikimedia.org/otrs/index.pl?Action=AgentTicketZoom;TicketID=10554532

Steps to reproduce
  1. Go to the article Provincias Unidas del Centro de América
  2. Open the quick/info box
  3. Go to another article Tear down this wall!
  4. Open the quick/info box
Expected

In steps 2 and 4, the media controls are shown not obscured/obscuring other content

Expected step 2 - play and download controls are shown below text
Expected step 4 - "Play media" is shown

Note that it is appearing as expected in the mweb and iOS app versions of these pages.

Actual

Media controls overlaps text in step 2, "Play media" not visible in step 4

Actual step 2
Actual step 4
Occurring on

Wikipedia v2.7.224-alpha-2018-01-26

Event Timeline

RHo created this task.Feb 2 2018, 8:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 2 2018, 8:50 PM
Pabloab added a subscriber: Pabloab.Feb 2 2018, 9:48 PM
Pabloab added a comment.EditedFeb 3 2018, 12:21 AM

Thanks Rita! I sent the first report from mobile app. On my device (Samsung Galaxy S5 with Android 6.0.1) the situation is much worst. Here is a screenshot what I see:

If I try to reproduce the bug with Chrome developer console > mobile view > Galaxy S5 the renderization is bad but not so terrible as actually is on the real device.
Is not necessary to clic the infobox, just scroll and there it is, cropped.

Arlolra added a subscriber: Arlolra.Feb 7 2018, 8:07 PM

Similar to T167600 in that what's happening seems to be browser dependent. In T133673 we arbitrarily set the height of audio tags to 20px, but Chrome's player's controls seem to have a height of 32px. Firefox controls appear to scale.

Minerva seems to set,

audio {
    height: 32px;
}
ssastry moved this task from Backlog to Non-Parsoid Tasks on the Parsoid board.Feb 26 2018, 4:28 PM
ovasileva triaged this task as Normal priority.Mar 13 2018, 11:05 AM
Jdlrobson added a subscriber: Jdlrobson.

Minerva seems to set,

audio {
    height: 32px;
}

I'm not seeing this anywhere.. The only mention of the audio tag inside "Minerva" is in the css reset file.

I'm not seeing this anywhere.. The only mention of the audio tag inside "Minerva" is in the css reset file.

Apologies, that's from the user agent stylesheet is Chrome.

Change 425900 had a related patch set uploaded (by Arlolra; owner: Arlolra):
[mediawiki/services/parsoid@master] Increase the default height mw:Audio to 32px

https://gerrit.wikimedia.org/r/425900

Change 425900 merged by jenkins-bot:
[mediawiki/services/parsoid@master] Increase the default height mw:Audio to 32px

https://gerrit.wikimedia.org/r/425900

Arlolra closed this task as Resolved.Apr 13 2018, 7:43 PM
Arlolra claimed this task.

"height" was bumped to 32 in that patch, and a new "mw-default-audio-size" class was added that can be targeted to override it.

Mentioned in SAL (#wikimedia-operations) [2018-04-30T20:27:25Z] <arlolra> Updated Parsoid to 50b0588 (T186358, T191700, T192909)