Message welcome bots at local wikis trigger due to edits at Wikidata
Closed, ResolvedPublic

Description

We have a mediawiki setting that allows a local wiki to welcome new users (not exactly sure of the mechanism, though I believe that it is Extension:NewUserMessage).

We have an issue where an edit at Wikidata is triggering the newusermessage to be delivered at the target wiki for the WD edit. This is quite disconcerting to have a welcome message appear at a wiki when you are not registered there, so let alone I haven't edited there.

Take into account that these are messages

  • from an unknown account, sometimes where there is no ability to translate the language
  • from a wiki where you have never been
  • where you have to guess that they are a welcome message, not a spam attack
  • not time-relevant to an edit that you made
  • the default settings at the new wiki make it difficult to see the context of the message (bot account; wikidata edits are hidden; delayed response to edit time)

Example, this edit at Wikidata

https://www.wikidata.org/w/index.php?title=Special:EntityPage/Q5296&curid=6240&diff=627751450&oldid=627679753
Revision as of 03:49, 7 February 2018

has been identified by many wikis to send me a variety of welcome messages over a period of time. One example:

https://hi.wikiversity.org/wiki/%E0%A4%B5%E0%A4%BF%E0%A4%B6%E0%A5%87%E0%A4%B7:RecentChanges?hidebots=1&hidecategorization=1&limit=500&days=7&urlversion=2

D विकिविश्वविद्यालय:मुखपृष्ठ (Q5296); 09:19 . . Billinghurst (talk | contribs) (Reverted edits by Manvydasz (talk) to last revision by Sjoerddebruin)

It has created 7 accounts for me, and I have received at least two messages. sort on "atttached on" Fortunately I had 800++ accounts already, otherwise it could have been a bit of a welcome message storm.

Can we please have one of the following implemented
a) newusermessage bot needs a physical edit on the wiki in questions rather than a shadow edit elsewhere; or
b) that WD edits are not visible to the extension

As a side note to WD, interesting to see the changes made at [03:49, 7 February 2018 ] still propagate through the wikis at [01:08, 10 February]

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 10 2018, 5:05 AM
Billinghurst renamed this task from Message welcome bot at local wikis trigger due to edits at Wikidata to Message welcome bots at local wikis trigger due to edits at Wikidata.Feb 10 2018, 5:15 AM

this bug seems to be fairly new, it has probably been introduced by a recent code change. I have just run into it and it is definitely a new behavior.

In WD there was the following report by @NicoScribe

...

Until December 2017, I had approximately 108 local accounts listed by meta:Special:CentralAuth/NicoScribe they were the consequences of my visits on 108 Wikimedia projects. But after the deployment of mw:MediaWiki 1.31/wmf.12 I had approximately 404 local accounts (whereas I have made almost no new visit). Now, after the deployment of mw:MediaWiki 1.31/wmf.20, I have approximately 509 local accounts (whereas I have made almost no new visit).

In December, I had a talk (in French) with @Trizek (WMF): everything is linked to T181731 and T179832.

Mahir256 edited subscribers, added: Trizek-WMF; removed: Trizek.Feb 11 2018, 8:06 AM

That explains why I keep getting these weird notifications for https://www.wikidata.org/wiki/Special:CentralAuth/NoclaimsBot . It's only configured to work on the wiki's listed at https://www.wikidata.org/wiki/User:NoclaimsBot#Overview

matej_suchanek added a subscriber: matej_suchanek.

NewUserMessage is only active on a few wikis (search "wmgUseNewUserMessage"), I doubt there is a problem (only) with this extension.

Per what was stated in T186977#3961490 (which is likely a duplicate task), this was caused by a database maintenance. So what is the goal of this task?

Billinghurst added a comment.EditedFeb 11 2018, 8:20 PM

Put the NewUserMessage back as it is the prime reason that I started the message. I wrote above what I wished to be achieved please see suggestion a) or b) in original message. [I also had confirmed that two wikis which I mentioned as sending welcome messages were in init file.]

In the end, that WD editing creates accounts is interesting, that it triggers the newusermessage bot is confusing. We should not be confusing, especially at wikis where the user doesn't edit, and cannot read the script/language of the incoming message, and cannot even translate the message through a tool.

Tgr closed this task as Resolved.Feb 13 2018, 3:42 AM
Tgr claimed this task.
Tgr added a subscriber: Tgr.

Per T183019#3890768 Wikidata is not causing local account creations anymore so there is nothing to do here. If someone wants to propose to change NewUserMessage and/or welcome bots to ignore users until their first edit (or do something clever like differentiate between user creations and user autocreations) that should be a separate task - it might or might not be wanted as a feature of its own, or as an extra layer of security against similar bugs in the future, but the bug that was discussed here doesn't exist anymore.