Page MenuHomePhabricator

Anonymous icons inconsistent on mobile
Closed, ResolvedPublic1 Estimated Story Points

Description

Original report

Salutations, I know, I'm bringing another request from the the VPT. But hey, I've been doing other stuff to. Anyways, anynomus users "179.228.224.8" and "201.42.15.101" have noticed a change in the emoticon system on the mobile view to a sleeping icon. I think it's normal, but they are worried what that's about. A little clarification please?

Steps to reproduce

  1. Go to: https://en.m.wikipedia.org/wiki/Special:Contributions/179.228.224.8
  2. Go to: https://en.m.wikipedia.org/wiki/Special:MobileDiff/827243649

Expected: both icons should be the same (the latter, "sleepy" icon is the correct one)
The fix is on the beta cluster so compare with:

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:Contributions/198.73.209.3
https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/376324

Developer notes

  • It looks like the Special:Contributions page doesn't pay attention to whether the user is anonymous and uses an icon mw-mf-user. Instead of doing this we'll want to check the user object (`$user->isAnon()`) and use the mw-ui-icon-mf-anonymous icon when the user is anonymous.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 25 2018, 4:43 PM
Zanygenius added a comment.EditedFeb 25 2018, 4:45 PM

: Adjusting assignment, trying to add @Xaosfulx (Xaos flux)
-Zacho

Aklapper changed the task status from Open to Stalled.Feb 25 2018, 5:23 PM
Aklapper removed Zanygenius as the assignee of this task.

Hi @Zanygenius, thanks for taking the time to report this!
Unfortunately this report lacks information. If you have time and can still reproduce the problem: Please add a more complete description to this report (a list of steps to reproduce which leave no room for interpretation what to do, describing actual results and expected results after performing the steps to reproduce, attaching or linking to a public testcase, etc). You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

This looks like a bug. consistency between anon icons in different places.

For now
We should fix the bug to show the 'sleepy' icon in both places.

For future
The sleepy icon was decided to indicate anonymity as part of 2014 wmf iconset. Design team is working on updating our icons and we will be getting rid of this sleepy emoji soon.

Here's before and after for registered user vs anonymous user for new iconset.

ovasileva renamed this task from {Mobile View on Wikipedia} Emoticon changes: Is it safe? to Anonymous icons inconsistent on mobile.Feb 26 2018, 4:59 PM
ovasileva changed the task status from Stalled to Open.
ovasileva triaged this task as Medium priority.
ovasileva updated the task description. (Show Details)Feb 26 2018, 5:01 PM
ovasileva updated the task description. (Show Details)
ovasileva moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.
Jdlrobson added subscribers: Volker_E, Jdlrobson.

cc @Volker_E (inconsistent icons ohhh noooo)

Jdlrobson updated the task description. (Show Details)Feb 26 2018, 7:52 PM

Do we want to update the icons as part of this task? Looks good to go estimation wise.

@Jdlrobson we can, but I wanted to have a better rollout plan for MW-UI. I will be creating an epic to overhaul icons on MW-UI. just like we have one on-going card for OOUI

Ok let's skip it. If we are updating lots of icons it's better to do that at once - there may be opportunities to start using icons in core thanks to the good work @Volker_E has been doing.

there may be opportunities to start using icons in core thanks to the good work @Volker_E has been doing.

ooooo

Jdlrobson updated the task description. (Show Details)Feb 27 2018, 5:31 PM
ovasileva set the point value for this task to 1.Feb 27 2018, 5:32 PM

Change 415179 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Use anonymous icon glyph if user being viewed is anonymous

https://gerrit.wikimedia.org/r/415179

pmiazga claimed this task.Feb 28 2018, 4:40 PM

Change 415179 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Use anonymous icon glyph if user being viewed is anonymous

https://gerrit.wikimedia.org/r/415179

Jdlrobson reassigned this task from pmiazga to ABorbaWMF.Mar 1 2018, 12:17 AM
Jdlrobson added a subscriber: pmiazga.
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)

This is fixed on Beta. @Jdlrobson, do we need to check again when deployed to production?

Jdlrobson reassigned this task from ABorbaWMF to ovasileva.Mar 1 2018, 7:03 PM
Jdlrobson added subscribers: ovasileva, ABorbaWMF.

Nope that should be sufficient. TO you @ovasileva

ovasileva closed this task as Resolved.Mar 5 2018, 11:49 AM

Sounds good! Thanks all.