Page MenuHomePhabricator

Thanking messages don’t check gender on Special:History
Closed, ResolvedPublic

Description

Thanks to Russian Wikipedia user AllaRo, we’ve noticed a bug in localisation: AJAX call that seems to check thanks log for edits that were thanked by me or other people doesn’t receive gender settings of either me or the person that I am thanking. So when I thanked a person with she/her preference, it gets displayed afterwards like this:

https://ru.wikipedia.org/wiki/Википедия:Форум/Технический?action=history

(текущ. | пред.) 19:20, 23 марта 2018‎ AllaRo (обсуждение | вклад)‎ . . (161 350 байт) (+1096)‎ . . (→‎Благодарность в закладке «История»: новая тема) (отменить | отблагодарён)

https://ru.wikipedia.org/wiki/Википедия:Форум/Технический?action=history&uselang=qqx

(parentheses: (cur)(pipe-separator)(last)) 19:20, 23 (march) 2018‎ AllaRo(word-separator)(parentheses: (talkpagelinktext)(pipe-separator)(contribslink))‎ . . (parentheses: (nbytes: 161,350)) (parentheses: +1,096)‎ . . (parentheses: →‎Благодарность в закладке «История»: новая тема) (parentheses: (editundo)(pipe-separator)(thanks-thanked))

As you can see, it passes no parameters in the message thanks-thanked that is replacing a thanking link (when both Saint Johann in my case and AllaRo should be passed), so in languages with gender-specific words this tool is misgendering people (instead of отблагодарён above [he was thanked], it should be отблагодарена [she was thanked]). The message on Translatewiki is fine, the problem seems to be with the script: https://translatewiki.net/wiki/MediaWiki:Thanks-thanked/ru

This should be easy to fix, so I hope someone can do this ASAP. Related to T96527.

Details

Related Gerrit Patches:

Event Timeline

stjn created this task.Mar 23 2018, 7:42 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 23 2018, 7:42 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Amire80 moved this task from Untriaged to Gender on the I18n board.Mar 24 2018, 3:12 PM
Catrope claimed this task.Mar 27 2018, 5:46 PM
Catrope added a subscriber: Catrope.

I can reproduce this, I'll work on fixing this shortly.

Change 422484 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Thanks@master] corethank: Use the recipient's gender for all "thanked" messages

https://gerrit.wikimedia.org/r/422484

Change 422484 merged by jenkins-bot:
[mediawiki/extensions/Thanks@master] corethank: Use the recipient's gender for all "thanked" messages

https://gerrit.wikimedia.org/r/422484

stjn closed this task as Resolved.Apr 13 2018, 8:42 AM

Resolved?

Tested it: yes. Although there seem to be some irregularities on when message even shows, but that is outside of the task and I can’t track its causes.

Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 14 2018, 1:14 AM