Page MenuHomePhabricator

AdvancedSearch does not show correct localized strings in Norwegian Bokmål
Closed, InvalidPublic

Description

I updated the localized messages for AdvancedSearch a few days ago, but the user interface still has some messages in other languages.

Note the messages "Ålmenn hjelp" (Swedish) and "Hugs vala for framtidige søk" (Nynorsk) from w:no:Specia:Search. These are "MediaWiki:Advancedsearch-namespaces-preset-general-help" and "MediaWiki:Advancedsearch-namespaces-remember" according to page loaded with language set to qqx. Inspecting they are locally "Generell hjelp" and "Husk valgene for fremtidige søk", that is they are updated. They are although not used in the user interface.

Event Timeline

jeblad created this task.May 10 2018, 10:03 AM
Restricted Application added a project: TCB-Team. · View Herald TranscriptMay 10 2018, 10:03 AM
Restricted Application added subscribers: Danmichaelo, jhsoby, Aklapper. · View Herald Transcript
jeblad updated the task description. (Show Details)
jeblad renamed this task from AdvancedSearch is not properly localized in Norwegian Bokmål to [bug] AdvancedSearch is not properly localized in Norwegian Bokmål.May 10 2018, 10:08 AM
Nikerabbit added a subscriber: Nikerabbit.

Why is it in Swedish? Swedish is not in the fallback languages for Norwegian.

The strings are correct in translatewiki.net and in the git repositories. There is no indication that this issue involves translatewiki.net.

Reedy renamed this task from [bug] AdvancedSearch is not properly localized in Norwegian Bokmål to AdvancedSearch is not properly localized in Norwegian Bokmål.May 10 2018, 12:29 PM
jeblad added a comment.EditedMay 10 2018, 2:13 PM

@Nikerabbit I have noe clue… I updated them at TranslateWiki, and they are updated at nowiki, but somehow they are not used. Pretty weird…

I was blaming Swedish, but no, it is valid Nynorsk. Some of the users at nnwiki writes a kind of archaic Nynorsk, and it is somewhat closer to Swedish. (Nynorsk vs. Bokmål)

Logged in with Chromium and the issue is visible there too. Previous test was with Firefox.

Aklapper renamed this task from AdvancedSearch is not properly localized in Norwegian Bokmål to AdvancedSearch does not show correct localized strings in Norwegian Bokmål.May 10 2018, 9:03 PM
Lea_WMDE edited projects, added WMDE-FUN-Team; removed TCB-Team.May 11 2018, 7:54 AM

@jeblad thanks for reporting the issue!

@Tonina_Zhelyazkova_WMDE @gabriel-wmde @Tim_WMDE @thiemowmde could someone have a look at it?

Thanks @jeblad for reporting!
I had a quick look at translate wiki and at the json file containing the strings for Norwegian Bokmål on the master branch of Advanced Search ( just to double check everything ). Translated strings on there are as you expect them - "Generell hjelp" and "Husk valgene for fremtidige søk". Therefor my first guess is this is a caching issue. I'll dig further and see if I can find something else wrong.

Update:
Turns out translations are applied once a day at 02:00 UTC from Monday through Thursday, according to https://wikitech.wikimedia.org/wiki/LocalisationUpdate
That means you'll probably see the updated messages on Monday. :/
To be on the extra safe side, I used a test server to make sure everything is ok with the nb messages. I did a manual pull so I can have the latest updates and the translations appear correctly.

Please let us know here if you still are experiencing the issue on Monday!
Happy searching :)

thiemowmde triaged this task as Low priority.May 11 2018, 10:10 AM
thiemowmde added a project: TestMe.
thiemowmde moved this task from Backlog to Watching on the Advanced-Search board.

So I just missed the weeks last update! =D

Aklapper closed this task as Invalid.May 27 2018, 10:11 PM

Items are shown in the correct language now and there was no software bug (just waiting for translation updates to get deployed), hence closing this task.

Vvjjkkii renamed this task from AdvancedSearch does not show correct localized strings in Norwegian Bokmål to 07caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Low to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from 07caaaaaaa to AdvancedSearch does not show correct localized strings in Norwegian Bokmål.Jul 2 2018, 7:51 AM
CommunityTechBot closed this task as Invalid.
CommunityTechBot lowered the priority of this task from High to Low.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.