Page MenuHomePhabricator

Fatal error: $this is null in Echo/includes/model/Event.php on line 345
Closed, ResolvedPublic

Description

Error Message

Fatal error: $this is null in /srv/mediawiki/php-1.32.0-wmf.4/extensions/Echo/includes/model/Event.php on line 345

Stack Trace

None available

Notes

This started with MediaWiki 1.32.0-wmf.4

I think this is triggered by a static call to a non-static method which was added in rECHObe88fc58c1af: Make NotificationJob json-serializable

Event Timeline

mmodell created this task.May 16 2018, 7:31 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMay 16 2018, 7:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
mmodell triaged this task as Unbreak Now! priority.May 16 2018, 7:31 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMay 16 2018, 7:31 PM

Mentioned in SAL (#wikimedia-operations) [2018-05-16T19:38:50Z] <twentyafterfour> The train for 1.32.0-wmf.4 is blocked by fatals in Echo extension. See T194848

@SBisson: Can you take a look at this?

mmodell renamed this task from Fatal error: $this is null in /srv/mediawiki/php-1.32.0-wmf.4/extensions/Echo/includes/model/Event.php on line 345 to Fatal error: $this is null in Echo/includes/model/Event.php on line 345.May 16 2018, 7:47 PM
mmodell updated the task description. (Show Details)

Change 433441 had a related patch set uploaded (by 20after4; owner: 20after4):
[mediawiki/extensions/Echo@wmf/1.32.0-wmf.4] Revert "Make NotificationJob json-serializable"

https://gerrit.wikimedia.org/r/433441

I'm not seeing any notifications since about 2 days in mediawiki.org from flow posts, even though my watchlist has changes from them. I assume the cause is this task, right? Or do you prefer to open a new task for investigation?

Mentioned in SAL (#wikimedia-operations) [2018-05-17T19:11:28Z] <twentyafterfour> train is still blocked by T194848

Change 433441 merged by jenkins-bot:
[mediawiki/extensions/Echo@wmf/1.32.0-wmf.4] Revert "Make NotificationJob json-serializable"

https://gerrit.wikimedia.org/r/433441

@Ciencia_Al_Poder Indeed that is probably caused by this one, however, I just merged the fix so if your problem persists it must be something else.

Mentioned in SAL (#wikimedia-operations) [2018-05-17T19:28:58Z] <twentyafterfour@tin> Synchronized php-1.32.0-wmf.4/extensions/Echo/: unbreak T194848 (duration: 01m 24s)

mmodell assigned this task to SBisson.May 17 2018, 7:29 PM
mmodell lowered the priority of this task from Unbreak Now! to High.

@SBisson: I only reverted this on the branch so we need to do something about it on master or we'll be dealing with it again next week.

@SBisson: I only reverted this on the branch so we need to do something about it on master or we'll be dealing with it again next week.

Of course I'll deal with this. Sorry for the inconvenience.

Lesson for me here: my mw-vagrant setup was NOT appropriate to test this.

@Ciencia_Al_Poder Indeed that is probably caused by this one, however, I just merged the fix so if your problem persists it must be something else.

Confirmed. I have new notifications today on mediawiki.org

mmodell closed this task as Resolved.May 22 2018, 8:30 PM

Indeed it is.

mmodell rescinded a token.May 22 2018, 8:31 PM
mmodell awarded a token.
Liuxinyu970226 awarded a token.
Liuxinyu970226 removed a subscriber: Liuxinyu970226.
Vvjjkkii renamed this task from Fatal error: $this is null in Echo/includes/model/Event.php on line 345 to vucaaaaaaa.Jul 1 2018, 1:09 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed SBisson as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from vucaaaaaaa to Fatal error: $this is null in Echo/includes/model/Event.php on line 345.Jul 2 2018, 6:46 AM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to SBisson.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.