Page MenuHomePhabricator

CX2: Failing to adapt an infobox leaves it loading forever
Closed, ResolvedPublic

Description

When translating an atricle with Content Translaiton, users often find an infobox template in it. Currently, adding an infobox can fail and remain "loading" forever:

There is a proposal to better communicate about templates that cannot be adapted (T192271), but as a first step we should avoid the perpetual loading state and show an empty paragraph when the adaptation process fails instead.

This issue was mentioned in a discussion, translating 1936 Cansiglio earthquake from English to Italian.

Event Timeline

Pginer-WMF triaged this task as Normal priority.Jun 12 2018, 12:31 PM
Pginer-WMF created this task.
Vvjjkkii renamed this task from CX2: Failing to adapt an infobox leaves it loading forever to f7aaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from f7aaaaaaaa to CX2: Failing to adapt an infobox leaves it loading forever.Jul 2 2018, 8:55 AM
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.

I tried with particular example and can't reproduce in Production (Spanish) or test instance (CX2) (Catalan).

Pginer-WMF closed this task as Resolved.EditedJul 18 2018, 3:37 PM
Pginer-WMF claimed this task.

I tried with particular example and can't reproduce in Production (Spanish) or test instance (CX2) (Catalan).

I tried also with English to Italian which was the original case reported and it seems to be working now. I'm marking the ticket as resolved. Feel free to reopen is a similar issue appears again.