Page MenuHomePhabricator

In mobile skins, Echo callout displays whitespace instead of notifications
Closed, ResolvedPublic

Description

See screenshot below. This only happens in the mobile view. Reproducible on desktop by making the browser width narrow enough (or using responsive design mode in dev tools).
The problem seems to be that the <div> with classes oo-ui-clippableElement-clippable oo-ui-popupWidget-body has an inline style width: 0px.

Details

Related Gerrit Patches:

Event Timeline

Evad37 created this task.Jun 13 2018, 6:54 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 13 2018, 6:54 AM

Change 441590 had a related patch set uploaded (by Evad37; owner: Evad37):
[mediawiki/skins/Timeless@master] Display notifications in echo callout for mobile view

https://gerrit.wikimedia.org/r/441590

RileyBugz moved this task from Backlog to Bugs on the Timeless board.Jun 23 2018, 4:58 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 29 2018, 6:45 PM
Vvjjkkii renamed this task from Timeless: In mobile view, Echo callout displays whitespace instead of notifications to b5aaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: gerritbot.
CommunityTechBot renamed this task from b5aaaaaaaa to Timeless: In mobile view, Echo callout displays whitespace instead of notifications.Jul 2 2018, 1:59 PM
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: gerritbot.

Change 441590 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Display notifications in echo callout for mobile view

https://gerrit.wikimedia.org/r/441590

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 18 2018, 5:16 PM
Isarra renamed this task from Timeless: In mobile view, Echo callout displays whitespace instead of notifications to In mobile skins, Echo callout displays whitespace instead of notifications.Jul 21 2018, 1:09 PM
Isarra removed a project: Timeless.
Isarra edited projects, added OOUI; removed Growth-Team, Patch-For-Review.
Isarra added a subscriber: Isarra.

Fixed for timeless in the above patch.

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 21 2018, 1:10 PM
Volker_E closed this task as Resolved.Aug 21 2018, 9:30 PM
Volker_E assigned this task to Evad37.
Volker_E added a subscriber: Volker_E.

This is no issue in MinervaNeue due to different notifications handling.

I think even though Wikimedia wikis use MinervaNeue, It is still a problem to solve of OOUI or of maybe OO.ui.PopupWidget I think.