Page MenuHomePhabricator

2017 wikitext editor does not update the address bar URL after edit save
Closed, ResolvedPublic

Description

Reported on English Wikipedia's technical village pump. After save, URL retains ?action=edit, and it shouldn't happen. Apparently sometimes returns article name "undefined" in Edge.

Event Timeline

Jc86035 created this task.Jun 18 2018, 4:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2018, 4:20 PM
Izno added a comment.Jun 18 2018, 5:16 PM

This happens in WTE 2017. I haven't looked to see if the same happens in VE.

matmarex added a subscriber: matmarex.

I can reproduce this – it only happens when you're using one of the single-edit-tab modes.

The 2017WTE is "VE"; it is a mode within Extension:VisualEditor. However, I can only reproduce this with a single edit tab that points to VisualEditor's wikitext mode. I can't reproduce this with an edit in VisualEditor's visual mode.

Change 441914 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] mw.DesktopArticleTarget: remove action=edit when tearing down as single-tab

https://gerrit.wikimedia.org/r/441914

DLynch claimed this task.Jun 25 2018, 4:59 PM
DLynch moved this task from Ready for Pick Up to Code review on the VisualEditor (Current work) board.

Didn't strictly need to save -- any teardown would cause it. It relied on the single-edit-tab behavior of switching from veaction to action in URLs.

Change 441914 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] mw.DesktopArticleTarget: remove action=edit when tearing down as single-tab

https://gerrit.wikimedia.org/r/441914

Deskana closed this task as Resolved.Jun 26 2018, 2:50 PM
Deskana triaged this task as Normal priority.
Vvjjkkii renamed this task from 2017 wikitext editor does not update the address bar URL after edit save to 0paaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed DLynch as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii edited subscribers, added: DLynch; removed: gerritbot, Aklapper.
AfroThundr3007730 renamed this task from 0paaaaaaaa to 2017 wikitext editor does not update the address bar URL after edit save.Jul 1 2018, 4:53 AM
AfroThundr3007730 closed this task as Resolved.
AfroThundr3007730 assigned this task to DLynch.
AfroThundr3007730 lowered the priority of this task from High to Normal.
AfroThundr3007730 updated the task description. (Show Details)
AfroThundr3007730 edited subscribers, added: GerritBot, Aklapper; removed: DLynch.