Page MenuHomePhabricator

CX2: Unable to translate en:Mulatto to es
Closed, DuplicatePublic

Description

CXXserver fails with Page en:Mulatto could not be found. TitleError: title-invalid-characters

As a result in Content Translation version 2 (tested in production), the user gets an error and the article does not load at all in the editor.

However, for version 1 the article loads normally.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 27 2018, 10:38 AM

Logstash reports error as:

MT processing error: TitleError: title-invalid-characters
    at _checkLegalTitleCharacters (/srv/deployment/cxserver/deploy-cache/revs/cc6dc61b96ef4c8b13a6154ada43f9d2fbbee839/node_modules/mediawiki-title/lib/index.js:253:15)
    at Function.Title.newFromText (/srv/deployment/cxserver/deploy-cache/revs/cc6dc61b96ef4c8b13a6154ada43f9d2fbbee839/node_modules/mediawiki-title/lib/index.js:402:5)
    at TitlePairRequest.<anonymous> (/srv/deployment/cxserver/deploy-cache/revs/cc6dc61b96ef4c8b13a6154ada43f9d2fbbee839/src/lib/mw/ApiRequest.js:264:19)
    at next (native)
    at resume (/srv/deployment/cxserver/deploy-cache/revs/cc6dc61b96ef4c8b13a6154ada43f9d2fbbee839/src/lib/util.js:277:21)
    at resumeNext (/srv/deployment/cxserver/deploy-cache/revs/cc6dc61b96ef4c8b13a6154ada43f9d2fbbee839/src/lib/util.js:287:26)
Pginer-WMF triaged this task as Medium priority.Jul 20 2018, 8:39 AM
Pginer-WMF moved this task from Backlog to Article loading on the CX-cxserver board.

This fails when this category is being checked for invalid characters. Since quotation mark is on a list of invalid chars, this fails with the error already described in the previous comment and in T189438.

Trying to load any article with that hidden category will fail as well.

I see the error when attempting to translate Reference section on any article where Apertium is present as an MT option.

santhosh closed this task as a duplicate of T189438: TitleError: title-invalid-characters.