Page MenuHomePhabricator

Characters appear after a delay when typing in large article translation
Closed, ResolvedPublic

Description

In the translation of large articles, such as en:Paris, typing has a very delayed response, and page appears hanged in between keypresses.

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterImprove section alignment performance
mediawiki/extensions/ContentTranslation : masterImprove section alignment performance
mediawiki/extensions/ContentTranslation : masterUse debounce to align section pairs instead of throttle

Event Timeline

santhosh created this task.Jun 29 2018, 8:59 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2018, 8:59 AM

A performance analys shows section aligment causes the pauses in the responsiveness

santhosh claimed this task.Jun 29 2018, 9:00 AM
santhosh triaged this task as High priority.

Change 443051 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Use debounce to align section pairs instead of throttle

https://gerrit.wikimedia.org/r/443051

Petar.petkovic moved this task from Needs Triage to CX2 on the ContentTranslation board.

Change 443058 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Improve section alignment performance

https://gerrit.wikimedia.org/r/443058

Change 443051 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Use debounce to align section pairs instead of throttle

https://gerrit.wikimedia.org/r/443051

Change 443058 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Improve section alignment performance

https://gerrit.wikimedia.org/r/443058

Petar.petkovic moved this task from In Review to QA on the Language-2018-Apr-June board.
Petar.petkovic removed a subscriber: gerritbot.
Nikerabbit renamed this task from Characters appear after a delay when typing in larget article translation to Characters appear after a delay when typing in large article translation .Jul 4 2018, 8:36 AM

Change 443943 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Improve section alignment performance

https://gerrit.wikimedia.org/r/443943

Etonkovidova closed this task as Resolved.Aug 11 2018, 1:09 AM
Etonkovidova added subscribers: Pginer-WMF, Etonkovidova.

Checked in cx2 - there is the improvement in performance time for mw.cx.ui.TranslationView.static.alignSectionPair (two samples are below):

But there is still a noticeable delay in characters appearing when typing. Such delay is not present in production.

@Pginer-WMF May be there should a more general task for performance evaluation? I am marking this task as Resolved for now.

Steps that were performed for testing:

  1. Start 'New translation' for en:Paris article
  2. Click on any paragraph to translate.
  3. When a paragraph is translated, start typing in the paragraph - the typed characters will appear with a delay.

Change 443943 abandoned by Santhosh:
Improve section alignment performance

Reason:
Need a fresh look into the root causes

https://gerrit.wikimedia.org/r/443943