Page MenuHomePhabricator

Switching between old WTE and visual editing doesn't preserve changes
Closed, ResolvedPublic

Description

User:Jo-Jo Eumerus reports that she is losing work when switching between wikitext and visual editing. Instead of content being preserved, switching makes her lose some of her work.

She is running the latest version of Firefox on Windows 10, with Vector. Her contributions indicate that she's using one of the older wikitext editors, and it's very likely the 2010 wikitext editor. See description at WP:VPT.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 15 2018, 9:25 PM
Whatamidoing-WMF updated the task description. (Show Details)
Izno added a subscriber: Izno.Jul 15 2018, 11:35 PM
Stryn added a subscriber: Stryn.Jul 16 2018, 3:43 PM
Deskana triaged this task as Normal priority.Jul 17 2018, 6:31 PM
Deskana edited projects, added VisualEditor (Current work); removed VisualEditor.
Deskana added a subscriber: Deskana.

I can't reproduce this with Chrome or Firefox on my Mac. I don't have access to my Windows machine right now. Regardless, data loss bugs need investigation.

Stryn added a comment.Jul 23 2018, 8:04 PM

I created a video to show the problem (https://youtu.be/2akrQGSWSUY).

DLynch claimed this task.Aug 2 2018, 4:58 PM
DLynch moved this task from Incoming to In progress on the VisualEditor (Current work) board.
DLynch added a subscriber: DLynch.

Not firefox specific. It does require that you have both multiple edit tabs, not be using NWE, and trigger the switch by clicking the "edit source" tab rather than through VE's menus, though, which I suspect is why Dan couldn't reproduce it.

Change 450160 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: always bind to #ca-edit

https://gerrit.wikimedia.org/r/450160

Change 450160 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: always bind to #ca-edit

https://gerrit.wikimedia.org/r/450160

Deskana closed this task as Resolved.Aug 17 2018, 9:26 AM