Page MenuHomePhabricator

CX2: All dialogs are opened in full screen, which breaks layouts
Closed, DeclinedPublic

Description

For example, the media dialog is not designed to be this large:

and the template dialog has far too much whitespace:

Event Timeline

Esanders created this task.Aug 17 2018, 6:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 17 2018, 6:51 PM

Does "full screen" means that dialog really covers entire viewport?
By design in T198390, dialogs are meant to cover the entire content. Since you added Regression, I wonder if something is broken with positioning.
Just checked on cx2-testing using Chrome 68 and dialog is sized as expected.

Pginer-WMF closed this task as Declined.Oct 19 2018, 10:04 AM
Pginer-WMF added a subscriber: Pginer-WMF.

The underlying issue does not seem to be specific to Content translation. I included below the same layout issues happening on the mobile version of visual editor. Once the form elements are improved with responsive support on the mobile editor to better support mobile devices such as tablets, those improvements will benefit Content translation too.

So I'm closing the ticket from our side.