Some property labels don't appear on beta
Closed, ResolvedPublic

Description

When testing Senses, some property labels are not displayed, instead the Pnumber is displayed.
Example on L1-F3, L1-S4, the reference on L12-S1.

Related Objects

Restricted Application added a project: Wikidata. · View Herald TranscriptAug 20 2018, 8:52 AM

Hey @WMDE-leszek, while testing stuff for Senses we encountered this weird bug. Could you have a look?

Looks like a bug of some sort, yes. Purging the cache wouldn't make the label show up.

Addshore added a subscriber: Addshore.EditedAug 20 2018, 1:37 PM

I went ahead and looked at this for 2 mins.

Using https://wikidata.beta.wmflabs.org/wiki/Lexeme:L1 and L1-S3 as an example
I noticed that the property P730 was pretty old, originally being created in 2014.
I edited the label https://wikidata.beta.wmflabs.org/w/index.php?title=Property:P730&diff=1050777&oldid=26249 and then it started appearing back on L1
I also changed it back https://wikidata.beta.wmflabs.org/w/index.php?title=Property:P730&diff=next&oldid=1050777 and it continued dispalying on L1.

I assume this is just some really legacy stuff / beta problems and I don't think it is a bug with Wikibase ot WikibaseLexeme

I imagine the other 3 links are similar cases, but I have not checked myself.

Addshore moved this task from Backlog to Watching on the User-Addshore board.
Addshore moved this task from incoming to needs discussion or investigation on the Wikidata board.

Oh, this is missing terms in wb_terms table (Isn't this table lovely? <3) It needs running "rebuldTermSqlIndex.php" in beta cluster. I do it right now.

Mentioned in SAL (#wikimedia-releng) [2018-08-21T10:37:31Z] <Amir1> ladsgroup@deployment-deploy01:~$ mwscript extensions/Wikibase/repo/maintenance/rebuildTermSqlIndex.php --wiki=wikidatawiki --rebuild-all-terms (T202260)

Okay, the script has finished now, can you check and tell if still there are issues? (purge to make sure)

Yay the problem is gone. Thanks :)

Addshore closed this task as Resolved.Aug 22 2018, 8:17 AM
Addshore claimed this task.
Addshore moved this task from Watching to Done ✔️ on the User-Addshore board.