Page MenuHomePhabricator

CX2: "Mark as missing" not working with undo
Closed, ResolvedPublic

Description

  1. Find some links which cannot be adapted and are displayed as gray (First paragraph of en:Ifakara has lots)
  2. Select the gray link and click on "Mark as missing" to make it a red link
  3. Click undo

Result: Nothing happens

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptAug 21 2018, 7:16 PM
Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald Transcript

I'd guess the problem is in ve.ce.CXLinkAnnotation.prototype.styleAnchor

Looks like this is a shallow copy issue. In general when you have a problem with undo - make sure that you are not directly modifying objects in the linear data store without cloning them.

Change 455560 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/ContentTranslation@master] Clone annotation before modifying

https://gerrit.wikimedia.org/r/455560

Petar.petkovic moved this task from Needs Triage to CX2 on the ContentTranslation board.
Petar.petkovic moved this task from Backlog to In Review on the Language-2018-July-September board.

Change 455560 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Clone annotation before modifying

https://gerrit.wikimedia.org/r/455560

Petar.petkovic moved this task from In Review to QA on the Language-2018-July-September board.
Petar.petkovic removed a subscriber: gerritbot.
Pginer-WMF closed this task as Resolved.Sep 3 2018, 7:03 AM
Pginer-WMF moved this task from QA to Done on the Language-2018-July-September board.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 3 2018, 7:03 AM