Page MenuHomePhabricator

Use local articlequality assessment scale for JADE.
Closed, ResolvedPublic

Description

Let's not deploy JADE for articlequality until the scale is localized. Currently we're using the Wikipedia 1.0 scale, incorrectly.

Event Timeline

awight created this task.Aug 28 2018, 10:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 28 2018, 10:01 PM

Change 456044 had a related patch set uploaded (by Awight; owner: Awight):
[mediawiki/extensions/JADE@master] [WIP] Replace generic APIs with specific ones

https://gerrit.wikimedia.org/r/456044

Harej triaged this task as Low priority.Sep 7 2018, 11:03 PM
Harej moved this task from Inbox to Feature Requests on the Jade board.
Harej moved this task from Feature Requests to In Progress on the Jade board.Sep 10 2018, 8:26 PM
awight claimed this task.Sep 17 2018, 4:33 PM
awight moved this task from Review to Active on the Machine Learning Platform (Current) board.

Change 461831 had a related patch set uploaded (by Awight; owner: Awight):
[mediawiki/extensions/JADE@master] Make articlequality scale configurable per wiki

https://gerrit.wikimedia.org/r/461831

Please ignore https://gerrit.wikimedia.org/r/456044, that has other features squashed in and will be abandoned.

@Halfak @Ladsgroup What do you think about squashing itemquality and articlequality scales into just articlequality? Now that the scale is configurable, are the pseudo-models conceptually similar enough that we can just present the single schema to editors?

I think they are different enough that they should be a different schema. E.g. the same classname means different things in different wikis. E.g. "B" from Wikidata and enwiki are very different.

Change 461831 merged by jenkins-bot:
[mediawiki/extensions/JADE@master] Make articlequality scale configurable per wiki

https://gerrit.wikimedia.org/r/461831

awight closed this task as Resolved.Oct 18 2018, 10:20 PM

Change 456044 abandoned by Ladsgroup:
[WIP] Replace generic APIs with specific ones

Reason:
This has merge conflict and requires so much work to bring to a state that can be useful. Also, this extension is being archived in favor its clone "Jade"

https://gerrit.wikimedia.org/r/456044