Page MenuHomePhabricator

TwoColConflict: Call to a member function getUser() on a non-object
Closed, ResolvedPublic1 Estimated Story PointsPRODUCTION ERROR

Description

I got this on testwiki after creating a new page:

[W4ajOQpAMFcAALGJkFIAAABJ] /w/index.php?title=Test-xxx&action=submit BadMethodCallException from line 311 of /srv/mediawiki/php-1.32.0-wmf.19/extensions/TwoColConflict/includes/InlineTwoColConflict/InlineTwoColConflictHelper.php: Call to a member function getUser() on a non-object (null)

Backtrace:

#0 /srv/mediawiki/php-1.32.0-wmf.19/extensions/TwoColConflict/includes/InlineTwoColConflict/InlineTwoColConflictHelper.php(159): TwoColConflict\InlineTwoColConflict\InlineTwoColConflictHelper->buildEditSummary()
#1 /srv/mediawiki/php-1.32.0-wmf.19/extensions/TwoColConflict/includes/InlineTwoColConflict/InlineTwoColConflictHelper.php(115): TwoColConflict\InlineTwoColConflict\InlineTwoColConflictHelper->buildConflictPageChangesCol()
#2 /srv/mediawiki/php-1.32.0-wmf.19/includes/EditPage.php(2901): TwoColConflict\InlineTwoColConflict\InlineTwoColConflictHelper->getEditFormHtmlBeforeContent()
#3 /srv/mediawiki/php-1.32.0-wmf.19/includes/EditPage.php(702): EditPage->showEditForm()
#4 /srv/mediawiki/php-1.32.0-wmf.19/includes/actions/EditAction.php(60): EditPage->edit()
#5 /srv/mediawiki/php-1.32.0-wmf.19/includes/actions/SubmitAction.php(38): EditAction->show()
#6 /srv/mediawiki/php-1.32.0-wmf.19/includes/MediaWiki.php(501): SubmitAction->show()
#7 /srv/mediawiki/php-1.32.0-wmf.19/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
#8 /srv/mediawiki/php-1.32.0-wmf.19/includes/MediaWiki.php(868): MediaWiki->performRequest()
#9 /srv/mediawiki/php-1.32.0-wmf.19/includes/MediaWiki.php(525): MediaWiki->main()
#10 /srv/mediawiki/php-1.32.0-wmf.19/index.php(42): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): include(string)
#12 {main}

Event Timeline

Tgr created this task.Aug 29 2018, 1:46 PM
Restricted Application added a project: archived--TCB-Team. · View Herald TranscriptAug 29 2018, 1:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Tgr added a comment.Aug 29 2018, 1:52 PM

The immediate cause is an unhandled null return in WikiPage::getRevision() - presumably the WikiPage is missing a loadPageData('fromdbmaster') call. The error is vaguely diff-related so could be caused by the recent MCR refactoring - maybe it changed loading order somehow.

Lea_WMDE set the point value for this task to 3.Sep 4 2018, 12:35 PM
Lea_WMDE added a subscriber: Lea_WMDE.

The story points are meant as investigation points, acting as a timebox as well.

Notes: This might be related to a page with an invalid title. Maybe it is related to an attempt to get data from a not yet populated replica.

Tgr added a comment.Sep 4 2018, 1:35 PM

The title was definitely valid (but freshly created). Probably replica lag, yeah; I'm not sure why it did not occur before, though.

Change 458194 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/TwoColConflict@master] Narrow HtmlSplitConflictHeader to not rely on it's (only) user

https://gerrit.wikimedia.org/r/458194

Lea_WMDE changed the point value for this task from 3 to 1.Sep 13 2018, 3:06 PM

@Tgr's suggestion probably solves the problem. So we will add it.

Change 458194 merged by jenkins-bot:
[mediawiki/extensions/TwoColConflict@master] Narrow HtmlSplitConflictHeader to not rely on it's (only) user

https://gerrit.wikimedia.org/r/458194

Lea_WMDE closed this task as Resolved.Sep 25 2018, 12:54 PM
Lea_WMDE triaged this task as Medium priority.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:09 PM