Page MenuHomePhabricator

CX2: Additional details for too much unmodified content error
Closed, ResolvedPublic

Description

Content translation shows an error when the translation has a high percentage of unmodified text (T190283). Currently the basic mechanism to prevent publishing has been supported, but it requires some adjustments in order to let users access more details about this problem.

Current state

Proposed changes

After trying to publishWhen checking the issue card
  • Adjust the error text message to remove the reference to "machine-translated":

Your translation cannot be published because it contains too much unmodified text.

  • Register the issue as an error in the Issue system (T189488). So that it appears in the Summary card (In the example the "1 error" in red is the associated item).
  • Provide a "View issues" link in the error message that acts as a shortcut to expand the issue card.
  • Create the details card for the error with the following messaging:

Your translation contains <pecentage of MT>% of unmodified text
Automatic translation is provided only as a starting point. Make sure that the content is accurate and reads naturally in your language.
Your translation is likely to be deleted when it is reviewed by other editors.
[Learn more]

For more details check the original spec in T190283

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterShow infobar error when publishing is canceled due to too much MT

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 3 2018, 9:08 AM
Arrbee moved this task from Needs Triage to CX2 on the ContentTranslation board.Sep 3 2018, 11:08 AM
Arrbee moved this task from CX2 to Bugs on the ContentTranslation board.

Change 506417 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Show infobar error when publishing is canceled due to too much MT

https://gerrit.wikimedia.org/r/506417

Change 506417 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Show infobar error when publishing is canceled due to too much MT

https://gerrit.wikimedia.org/r/506417

Etonkovidova updated the task description. (Show Details)May 3 2019, 12:12 AM
Etonkovidova added a subscriber: Etonkovidova.EditedMay 3 2019, 12:29 AM

Checked in enwiki ( wmf.3).
@Petar.petkovic - my comments on the items that were marked with exclamation points ( and ).

(1)

Adjust the error text message to remove the reference to "machine-translated":

Presently the messages still includes "machine-translated" reference:

(2)

Register the issue as an error in the Issue system (T189488). So that it appears in the Summary card (In the example the "1 error" in red is the associated item).

This is a tricky one. As far as I could see, it adds one more count to overall count of issues on a translation. Is it intended behavior that +1 issue is added by that warning?

(3)

  • Create the details card for the error with the following messaging:

Your translation contains <pecentage of MT>% of unmodified text
Automatic translation is provided only as a starting point. Make sure that the content is accurate and reads naturally in your language.
Your translation is likely to be deleted when it is reviewed by other editors.
[Learn more]

Example: one paragraph is translated with "Copy original contnet". The count will be - 1 error and 1 warning. The both issue cards do not have the text above. The issue text card refers to "machine translation" although only "Copy original content" was used.
Also these two issue cards have identical text but, in fact, one is an error and another one is a warning.

Checking in cx2-testing - the message in (3) is actually correct - it's just not present in enwikiwmf.3.

Checked in enwiki (wmf.3).
@Petar.petkovic - my comments on the items that were marked with exclamation points ( and ).
(1)

Adjust the error text message to remove the reference to "machine-translated":

Presently the messages still includes "machine-translated" reference:

This might be caused by some caching. The message is changed in the code base.

(2)

Register the issue as an error in the Issue system (T189488). So that it appears in the Summary card (In the example the "1 error" in red is the associated item).

This is a tricky one. As far as I could see, it adds one more count to overall count of issues on a translation. Is it intended behavior that +1 issue is added by that warning?

When user tries to publish, but article has too much unmodified content, they encounter an error. The error was only shown inside infobar, below the publish button line. This ticket was about registering the same error inside issue card system. When new warning or error is registered inside issue card system, the counters increase. That being said, the behavior is expected.

(3)

  • Create the details card for the error with the following messaging:

Your translation contains <percentage of MT>% of unmodified text
Automatic translation is provided only as a starting point. Make sure that the content is accurate and reads naturally in your language.
Your translation is likely to be deleted when it is reviewed by other editors.
[Learn more]

Example: one paragraph is translated with "Copy original content". The count will be - 1 error and 1 warning. The both issue cards do not have the text above. The issue text card refers to "machine translation" although only "Copy original content" was used.
Also these two issue cards have identical text but, in fact, one is an error and another one is a warning.


Warning is for paragraph containing 100% unmodified text. Error is for whole translation. Since whole translation consists of one paragraph, that means MT percentage for one paragraph is MT percentage for the whole article.

Etonkovidova updated the task description. (Show Details)May 7 2019, 10:05 PM
Etonkovidova updated the task description. (Show Details)

Re-checked in wmf.4 - and marked all specs as done and verified.

Two questions:
(1) @Petar.petkovic, @Pginer-WMF I still think that "double" counting is confusing. Yes, there is some logic in treating "publishing error" as a separate error. The error cannot be 'Resolved' for example vs warnings that have 'Mark as resolved' option. From the user point of view, it's sill double-counting of errors. One paragraph that triggers too-much-unmodified warning will click an additional error - with identical warning. It does not even say - Publishing error or something.
Another argument against adding - logically it's not a separate error; the publishing error is a summary of other issues in the issue card.

(2) The warning "Your translation contains <%MT>" refers to "Automatic translation is provided ..." when a user might use "Copy original content" option. The error handling is the same for "Copy original content" as for MT.
Should the text in "Automatic translation is provided..." message in the issue card be more generic and refer to "unmodifed text" or something like "MT and Copy original content options are provided ..."?

Etonkovidova closed this task as Resolved.May 7 2019, 10:25 PM