Page MenuHomePhabricator

Forcing type Language on Skin::doEditSectionLink generates a warning on `MinervaNeue` and possibly other skins that override this method
Closed, ResolvedPublic

Description

Forcing type Language on Skin::doEditSectionLink generates a warning on MinervaNeue and possibly other skins that override this method

This is the change:
https://gerrit.wikimedia.org/r/c/mediawiki/core/+/447505

Here is the warning

Warning: Declaration of SkinMinerva::doEditSectionLink(Title $nt, $section, $tooltip = NULL, $lang = false) should be compatible with Skin::doEditSectionLink(Title $nt, $section, $tooltip, Language $lang) in /vagrant/mediawiki/skins/MinervaNeue/includes/skins/SkinMinerva.php on line

Event Timeline

dmaza created this task.Oct 18 2018, 8:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 18 2018, 8:02 PM

Change 447502 had a related patch set uploaded (by Fomafix; owner: Fomafix):
[mediawiki/skins/MinervaNeue@master] Force type Language for $lang of doEditSectionLink

https://gerrit.wikimedia.org/r/447502

Yes, https://gerrit.wikimedia.org/r/447502 removes this warning. I can reproduce this.

dmaza added a comment.Oct 18 2018, 8:16 PM

That fixes MinervaNeue. I'm not sure how to check if this happens in other skins

https://codesearch.wmflabs.org/search/?q=doEditSectionLink finds no other skins. There may by external skins.

Change 447502 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Force type Language for $lang of doEditSectionLink

https://gerrit.wikimedia.org/r/447502

Jdlrobson closed this task as Resolved.Oct 19 2018, 5:47 PM
Jdlrobson claimed this task.

Looks like we are done here!