Page MenuHomePhabricator

Flow/TemplateHelper.php: PHP Notice: Undefined index "posts"
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

Request ID: W9Cd3wpAMFkAAIcA368AAADH

message
PHP Notice: Undefined index: posts
trace
#0 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/TemplateHelper.php(341): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.33.0-wmf.1/vendor/zordius/lightncandy/src/lightncandy.php(2718): Flow\TemplateHelper::eachPost(array, array, array)
#2 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/handlebars/compiled/flow_block_topic_moderate_post.handlebars.php(239): LCRun3::hbch(array, string, array, array, boolean, Closure$#40;4040)
#3 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/TemplateHelper.php(113): Closure$#41(array, array)
#4 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/TemplateHelper.php(188): Closure$Flow\TemplateHelper::getTemplate(array, array)
#5 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/TemplateHelper.php(304): Flow\TemplateHelper::processTemplate(string, array)
#6 /srv/mediawiki/php-1.33.0-wmf.1/vendor/zordius/lightncandy/src/lightncandy.php(2602): Flow\TemplateHelper::block(array, array)
#7 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/handlebars/compiled/flow_block_loop.handlebars.php(25): LCRun3::ch(array, string, array, string)
#8 /srv/mediawiki/php-1.33.0-wmf.1/vendor/zordius/lightncandy/src/lightncandy.php(2485): Closure$(array, array)
#9 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/handlebars/compiled/flow_block_loop.handlebars.php(26): LCRun3::sec(array, array, array, boolean, Closure$;3383)
#10 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/TemplateHelper.php(113): Closure$#2(array, array)
#11 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/View.php(375): Closure$Flow\TemplateHelper::getTemplate(array)
#12 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/View.php(87): Flow\View->renderApiResponse(array, array)
#13 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/Actions/Action.php(112): Flow\View->show(Flow\WorkflowLoader, string)
#14 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Flow/includes/Actions/Action.php(50): Flow\Actions\FlowAction->showForAction(string)
#15 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(501): Flow\Actions\FlowAction->show()
#16 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
#17 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(860): MediaWiki->performRequest()
#18 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(517): MediaWiki->main()
#19 /srv/mediawiki/php-1.33.0-wmf.1/index.php(42): MediaWiki->run()

Impact

Unknown.

Notes

This is a regression that started with 1.32.0-wmf.24, seen since on 1.32.0-wmf.26 and this week on 1.33.0-wmf.1. Affected mediawiki.org and Wikipedia it seems.

Event Timeline

Krinkle created this task.Oct 24 2018, 5:47 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 24 2018, 5:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Seems to happen on 1.34.0-wmf.14 as well. server www.mediawiki.org, reqid XTBhNwpAMFMAAAuMBcIAAABY on logstash. Since it's an old issue, I'm not treating it as a blocker, though.

JTannerWMF moved this task from Inbox to Q1 2019-20 on the Growth-Team board.Jul 23 2019, 8:44 PM
JTannerWMF added a subscriber: JTannerWMF.

The Growth-Team will take a look at this.

Change 532967 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/Flow@master] Fix PHP Notice: Undefined index: posts

https://gerrit.wikimedia.org/r/532967

kostajh claimed this task.Aug 28 2019, 10:43 AM
kostajh edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
kostajh moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:08 PM

Change 532967 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Fix PHP Notice: Undefined index: posts

https://gerrit.wikimedia.org/r/532967

Etonkovidova closed this task as Resolved.Sep 5 2019, 9:46 PM