Page MenuHomePhabricator

First context menu shown after opening the page is all broken
Closed, ResolvedPublic

Description

First context menu shown after opening the page is all broken.

Clicking elsewhere and then again in the previous place displays a normal context menu.

Event Timeline

matmarex created this task.Nov 2 2018, 3:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 2 2018, 3:12 PM

Seeing this too, wonder if this is related to the issue I saw with the notices popup:

i.e. an OOUI regression? Was any OOUI popup code changed?

Esanders added a comment.EditedNov 3 2018, 12:56 PM

Locally bisecting it's definitely an OOUI regression, most likely https://gerrit.wikimedia.org/r/#/c/oojs/ui/+/467000/

Esanders triaged this task as Unbreak Now! priority.Nov 3 2018, 1:01 PM
Esanders added a project: OOUI.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptNov 3 2018, 1:01 PM

Setting needsCustomPosition to true appears to fix this. Bartosz suggesting removing that check in the patch, but I'll leave it up to him.

Ping. Train will depart in 24 hours with or without a fix to this…

matmarex claimed this task.Nov 5 2018, 7:19 PM

Seeing this too, wonder if this is related to the issue I saw with the notices popup:

I think this is not related to the other issue. I couldn't reproduce this under normal circumstances, but it does happen when you make your browser window ridiculously tiny (there has to be more space above the toolbar than below it):

Patch for that: https://gerrit.wikimedia.org/r/#/c/oojs/ui/+/471790 (not marking against this task since this is a bit off-topic).

Change 471796 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[oojs/ui@master] FloatableElement: Remove check for 'needsCustomPosition'

https://gerrit.wikimedia.org/r/471796

Change 471797 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] OOUI: Backport I407b0d6fe7b81465054b640d4b5ac4bf352a9901

https://gerrit.wikimedia.org/r/471797

@Esanders Thanks for debugging.

The issue can also be reproduced in the OOUI demo. Visit https://doc.wikimedia.org/oojs-ui/master/demos/?page=dialogs, open "PopupButtonWidget test" at the bottom, and uncheck "Use overlay". All of the popups will display below/forwards when opened for the first time, regardless of how they should be displayed.

Change 471796 merged by jenkins-bot:
[oojs/ui@master] FloatableElement: Remove check for 'needsCustomPosition'

https://gerrit.wikimedia.org/r/471796

Change 471797 merged by jenkins-bot:
[mediawiki/core@master] OOUI: Backport I407b0d6fe7b81465054b640d4b5ac4bf352a9901

https://gerrit.wikimedia.org/r/471797

Change 472080 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Update OOUI to v0.29.4

https://gerrit.wikimedia.org/r/472080

Change 472080 merged by jenkins-bot:
[mediawiki/core@master] Update OOUI to v0.29.4

https://gerrit.wikimedia.org/r/472080

Volker_E closed this task as Resolved.Nov 12 2018, 12:54 AM
Volker_E moved this task from Backlog to OOUI-0.29.4 on the OOUI board.
Volker_E edited projects, added OOUI (OOUI-0.29.4); removed OOUI.
Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.