Page MenuHomePhabricator

Summary-links not correct
Closed, ResolvedPublic

Description

Following appears on the German Wikipedia:
When I edit an article (for example "Teddy") using the VE and write in the summary something like "[...] /*relevant section*/" (which should add a link to the section I edited) and go back to the overview of changes before saving, the link in the summary-preview is "https://de.wikipedia.org/wiki/API#relevant_section" which isn't correct because I edited the article "Teddy".
It must be "https://de.wikipedia.org/wiki/Teddy#relevant_section". I think it's a problem that VE interact's as overlay and works as API but that's just a first, superficial opinion.

Event Timeline

Der_Keks created this task.Nov 7 2018, 6:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 7 2018, 6:28 PM

I can't reproduce this in Safari 12 on macOS 10.13. (It just ignores my hand-typed section headings.) Do you have browser information?

Just to clarify, this is only about this link in the diff/preview dialog, correct? (it indeed points to the wrong place)

"API" is used by the API as a placeholder in some cases when the right title is not provided.

I wasn't really planning to work on this, but after I found the bug, it took no time to fix…

Change 475935 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] ve.ui.MWSaveDialog: Improve handling of links in edit summary preview

https://gerrit.wikimedia.org/r/475935

Change 475935 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] ve.ui.MWSaveDialog: Improve handling of links in edit summary preview

https://gerrit.wikimedia.org/r/475935

Just to clarify, this is only about this link in the diff/preview dialog, correct? (it indeed points to the wrong place)

"API" is used by the API as a placeholder in some cases when the right title is not provided.

correct!

Esanders moved this task from Inbox to Low Priority on the Editing QA board.Dec 13 2018, 4:05 PM
Ryasmeen edited projects, added Verified; removed Editing QA.Jan 11 2019, 11:03 PM
marcella closed this task as Resolved.Jan 15 2019, 2:28 PM