Page MenuHomePhabricator

currency mismatch between Ingenico Connect & Civi
Closed, ResolvedPublic2 Story Points

Description

A French donor cid=27543831 has a recurring donation of EUR 3.00 that's processed twice, 4000623881 and 4000291375. At the Ingenico console these donations appear as $3.45 USD. This donor has reported a bank fee being applied to each donation.

Is it possible that a currency conversion is happening somewhere it ought not?

Event Timeline

MBeat33 created this task.Dec 3 2018, 3:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 3 2018, 3:45 PM
MBeat33 triaged this task as High priority.Dec 14 2018, 4:25 PM

We have another case, recurring Ingenico invoice 60745094.2|recur-1544573356

We need to refund the second payment, as it was not intended to be recurring.
Civi says Source = GBP 2.00
Ingenico says Order and Req Amount = $2.62 USD

Which value should we refund at the console?

Ejegg added a subscriber: Ejegg.Dec 14 2018, 6:16 PM

Guessing this is linked to T210473

Ejegg added a comment.Jan 8 2019, 4:28 PM

Oh darn, it looks like we're using the converted (USD) amount for recurring payments in the new Ingenico API. I'll switch that over ASAP to use the original currency.

Ejegg claimed this task.Jan 8 2019, 4:29 PM
Ejegg moved this task from Backlog to Doing on the Fundraising Sprint XML ate my homework board.

Change 482841 had a related patch set uploaded (by Ejegg; owner: Ejegg):
[wikimedia/fundraising/crm@master] SmashPig recurring: charge in original currency

https://gerrit.wikimedia.org/r/482841

Change 482841 merged by jenkins-bot:
[wikimedia/fundraising/crm@master] SmashPig recurring: charge in original currency

https://gerrit.wikimedia.org/r/482841

Ejegg added a comment.Jan 10 2019, 5:40 PM

@Eileenmcnaughton No, I think these are actually separate issues.

Ejegg closed this task as Resolved.Jan 11 2019, 8:23 PM

Verified with payment 4000928094 - initiated in DKK, but the December payment was in USD. The January payment was (correctly) in DKK again.

Ejegg added a comment.Jan 11 2019, 8:35 PM

Oops @Eileenmcnaughton , they DO have the same root cause! So, for this issue, we were charging people's recurring donations in USD but recording the contribution as though we had charged them in the original currency. I'll see what I can do to fix the contribution records (so they reflect the reality that we charged people in USD for a month or two).

Then we can re-queue the refunds.

mepps added a subscriber: mepps.Jan 23 2019, 8:19 PM

@Ejegg have we tidied this up in civi? Otherwise we should create a separate ticket for that work.

Ejegg added a comment.Jan 24 2019, 6:14 PM

Yes @mepps, we did tidy this up in Civi - the patch to do that was attached to T210473

Ejegg set the point value for this task to 2.Jul 5 2019, 1:22 AM