Page MenuHomePhabricator

Support Translation for CE Insights
Closed, ResolvedPublic

Description

What is the problem?

In Q3 we will begin the process for translated CE Insights. The translated content that needs to be reviewed are survey questions, while the content that needs to be translated and reviewed are the messaging associated with the survey (e.g. survey invitations and reminders). This process would include professional translation, but also community review of these translations.

How can we help you?

I need help with:

  • Recruiting & engaging with volunteer translators
  • Help with designing & implementing a process for volunteer translators to review translations for survey questions and to translate survey messaging. Currently the languages include ar, es, de, en, fr, it, ja, nl, pt, ru, zh. We may also collaborate with Niklas Lakstrom to improve a tool used to transfer content from Mediawiki to Qualtrics and vice versa.
  • Working on a glossary that could be sent to Qualtrics translators.
  • Identify which Chinese language variant is most optimal based on who edits the projects.

In the past I have worked with Benoit, but I understand that he might be too busy during the time frame of the project. I have already discussed the current process with Benoit.

Additional details can be found at this google doc: https://docs.google.com/document/d/1ZEB2d8BwBsqlHv557ECuPD2fazCouXHgB5jLzZZXQuY/edit

    1. What does success look like?
  • A survey that is fully translated and vetted for quality to improve completion rates
  • Survey messaging translated to help gain response rates for the survey.

What is your deadline?

This project would start around the end of January and run through the end of March.

Thanks!
Edward

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 5 2018, 6:20 PM
Elitre removed Elitre as the assignee of this task.Dec 6 2018, 1:09 PM
Elitre triaged this task as Medium priority.
Elitre added a subscriber: Elitre.

Thanks for filing this. We'll triage soon.

Edward, FYI we're discussing this request already. While I can't promise that I can attach a name to it before EOY, there's no doubt we're going to resource it in due course. HTH.

Elitre awarded a token.Jan 8 2019, 1:35 PM

Hi @egalvezwmf ! I left a number of comments on the planning doc. I need to have clarity around the following things:

  • how many languages are we working with? you mentioned 10, but there are 11 languages specified.
  • what tasks you need volunteer translators for?
  • what purpose does the glossary serve?
  • who will be creating the glossary?
  • when do you need the glossary by?
mcruzWMF changed the task status from Open to Stalled.Apr 17 2019, 6:34 PM

After meeting with Jaime Anstee and Dana McCurdy, I decided to stall this task, as the future of CE Insights is yet to be determined.

Qgil added a subscriber: Qgil.

(Doh, sorry for the noise.)

Qgil added a comment.Jul 22 2019, 2:52 PM

Does T228548: Volunteer translator help for Community Insights Survey that this task is completed? Is it a duplicate of sorts?

Elitre added a subscriber: Rmaung.Jul 31 2019, 8:43 AM

Does T228548: Volunteer translator help for Community Insights Survey that this task is completed? Is it a duplicate of sorts?

@Rmaung , maybe you can answer this?

It does look like a duplicate, though it looks like this ticket was stalled in April so I'm not sure if any progress was made that would affect T228548. Theoretically, the CI survey should change far less in the future, and we should have (1) a solid translation of each language version and (2) the information we need for a glossary following completion of T228548. Apologies if I'm misunderstanding the point, but if your question @Qgil is whether this ticket can be closed, then from my perspective yes it can!

Elitre closed this task as Resolved.Aug 29 2019, 8:45 AM