Page MenuHomePhabricator

[wmf.8-regression] Flow pages - "Cannot read property 'trim' of undefined" crashes the page
Closed, ResolvedPublic

Description

On mediawiki go to any Flow-based page. Even on an empty board, the loading the page produces "Uncaught TypeError: Cannot read property 'trim' of undefined".

The Flow page is completely broken - no editing is possible.

Note: The error appears about a week ago in betalabs, but it did not affect Flow's functionality.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 11 2018, 5:26 PM
Etonkovidova triaged this task as Unbreak Now! priority.Dec 11 2018, 5:27 PM
Etonkovidova edited subscribers, added: Jdforrester-WMF; removed: Etonkovidova.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptDec 11 2018, 5:27 PM

Can you provide a link?

Change 479003 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/Flow@master] Check data.target exists before trimming

https://gerrit.wikimedia.org/r/479003

Change 479004 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@master] Fix JS error: don't .trim() a potentially undefined value

https://gerrit.wikimedia.org/r/479004

Change 479004 abandoned by Jforrester:
Fix JS error: don't .trim() a potentially undefined value

Reason:
Dupe of I0949fe1464. Four minutes too slow. ;-)

https://gerrit.wikimedia.org/r/479004

Change 479003 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Check data.target exists before trimming

https://gerrit.wikimedia.org/r/479003

Change 479016 had a related patch set uploaded (by Jforrester; owner: Esanders):
[mediawiki/extensions/Flow@wmf/1.33.0-wmf.8] Check data.target exists before trimming

https://gerrit.wikimedia.org/r/479016

Change 479016 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.33.0-wmf.8] Check data.target exists before trimming

https://gerrit.wikimedia.org/r/479016

Mentioned in SAL (#wikimedia-operations) [2018-12-11T19:28:41Z] <jforrester@deploy1001> Synchronized php-1.33.0-wmf.8/extensions/Flow/modules/engine/misc/flow-handlebars.js: T211707 Hot-deploy fix for StructuredDiscussions pages (duration: 00m 52s)

Etonkovidova closed this task as Resolved.Dec 11 2018, 10:19 PM

Checked the fix in wmf.8 (testwiki).