Page MenuHomePhabricator

Enable UserFeedback Gadget on MediaWiki.org
Closed, ResolvedPublic

Description

One of the big piece of this GSoC project: T219193 would be to add a tabbed window on all API pages in the Help namespace on MediaWiki.org. This tabbed window will show sample code in different programming languages showing how to make use of an API module.

Though, the UserFeedback gadget was initially deployed on Wikitech (and it worked well there): T213782, it would be good to have this enabled on MediaWiki now. This will help us learn if the documentation improvements made as part of the Outreach program projects to API docs were helpful or not.

Steps to do so I imagine would be:

Event Timeline

srishakatux triaged this task as Normal priority.
srishakatux created this task.
srishakatux updated the task description. (Show Details)Jun 12 2019, 3:26 AM

Asking here if anyone has any concerns in doing so: https://www.mediawiki.org/wiki/Topic:V1gwsbljqo1lzwul.

Aklapper updated the task description. (Show Details)Jun 12 2019, 9:16 AM
Tomybrz added a subscriber: Wargo.Jun 12 2019, 1:29 PM

For the step 2, actually only one interface admin is active the last 30 days ; it's @Wargo (Special:ActiveUser), If he not responding, you can ask to a global interface admin or a staff.

Anomie moved this task from Unsorted to Non-Code on the MediaWiki-API board.Jun 12 2019, 2:14 PM

Gadget enabled and can now be activated on Special:Preferences, see the post.

Personnal feedback : it's possible to create OOUI like and dislike ? The actual "emoji" looks weird compared to the rest of the page

@Tomybrz @Wargo Thank you so much for quick response on this! I've two more changes to request:

Thanks again for all your help!

Wargo added a comment.Jun 13 2019, 9:09 AM

Could you confirm it changed?

Tomybrz added a comment.EditedJun 13 2019, 10:51 AM

Could you confirm it changed

yeah working, also confirmed as default gadget

srishakatux closed this task as Resolved.Jun 13 2019, 8:22 PM

Thank you very much @Wargo & @Tomybrz! It works :)

Can you make messages translatable?

Tomybrz reopened this task as Open.Jun 15 2019, 1:40 PM
Tomybrz updated the task description. (Show Details)Jun 15 2019, 1:47 PM

@Shirayuki @Tomybrz I don't seem to find a quick method to make messages in the form translatable. I see this documentation https://www.mediawiki.org/wiki/Extension:Gadgets/Gadgets_2.0#Adding_multi-language_support_to_a_gadget but it is for 2.0 :-/ If I find an easy fix for this, I will work on it soon!

Aklapper renamed this task from Enable UserFeedback Gadget on MediaWiki to Enable UserFeedback Gadget on MediaWiki.org.Jun 18 2019, 3:06 AM

IMHO separate tasks should be filed as separate tasks.
This task called "Enable UserFeedback Gadget on MediaWiki" should be resolved because the UserFeedback gadget is now enabled on MediaWiki.org.

Tomybrz closed this task as Resolved.Jun 18 2019, 7:38 AM