Page MenuHomePhabricator

stream.wikimedia.org/?doc returns an error page
Closed, ResolvedPublic

Description

https://stream.wikimedia.org/?doc returns the following text:

Unable to render this definition

swagger and openapi fields cannot be present in the same Swagger or OpenAPI definition. Please remove one of the fields.

Supported version fields are swagger: "2.0" and those that match openapi: 3.0.n (for example, openapi: 3.0.0).

It should return a working documentation.

Event Timeline

stjn created this task.Jul 13 2019, 9:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 13 2019, 9:50 PM
Quiddity added a subscriber: Quiddity.
WDoranWMF removed a project: Core Platform Team.
WDoranWMF added subscribers: Ottomata, WDoranWMF.

Untagging CPT and adding @Ottomata, please let me know if this is incorrect.

Change 524027 had a related patch set uploaded (by Ottomata; owner: Ottomata):
[mediawiki/services/eventstreams@master] Use openapi 3.0.0 instead of swagger 2.0

https://gerrit.wikimedia.org/r/524027

Change 524027 merged by Ottomata:
[mediawiki/services/eventstreams@master] Use openapi 3.0.0 instead of swagger 2.0

https://gerrit.wikimedia.org/r/524027

Change 524032 had a related patch set uploaded (by Ottomata; owner: Ottomata):
[mediawiki/services/eventstreams/deploy@master] Use openapi: 3.0.0 instead of swagger 2.0 in eventstreams spec.yaml template

https://gerrit.wikimedia.org/r/524032

Change 524032 merged by Ottomata:
[mediawiki/services/eventstreams/deploy@master] Use openapi: 3.0.0 instead of swagger 2.0 in eventstreams spec.yaml template

https://gerrit.wikimedia.org/r/524032

Mentioned in SAL (#wikimedia-operations) [2019-07-17T21:07:35Z] <otto@deploy1001> Started deploy [eventstreams/deploy@dbc9bbb]: Fix ?doc to use openapi instead of swagger - T227958

Mentioned in SAL (#wikimedia-operations) [2019-07-17T21:10:28Z] <otto@deploy1001> Finished deploy [eventstreams/deploy@dbc9bbb]: Fix ?doc to use openapi instead of swagger - T227958 (duration: 02m 52s)

Thank you! Fixed. This was caused by an update to the service-template-node version we used. spec.yaml used by ?doc was not updated properly.

Ottomata moved this task from Next Up to Done on the Analytics-Kanban board.

Hm, I think varnish still has /?spec cached on some frontends. Not sure how long it takes for that to get purged, but I assume it eventually will.

Milimetric closed this task as Resolved.Jul 18 2019, 4:35 PM
Milimetric triaged this task as High priority.
Milimetric moved this task from Incoming to Operational Excellence on the Analytics board.
stjn added a comment.Jul 18 2019, 4:42 PM

Is component documentation supposed to contain nothing? In fact, there are multiple React errors on doing any action on the page. (Firefox 68.) Sorry if that’s a topic for a new task, the page still is effectively not working, just in a different way.