Page MenuHomePhabricator

Investigate if the code of Graphoid uses a proper user agent header
Closed, ResolvedPublic

Description

One of the possible reasons for the issues with Graph extension is that the code would not comply to the new requirements of the Query Service: using a user-agent header to identify tools sending queries.

The first step would be to check on Graphoid's code to check if the tool is sending a user-agent header ; if so, we can exclude this option from the possible reasons.

Timebox to max 4h.

Details

Related Gerrit Patches:
mediawiki/services/graphoid : masterImprove user agent

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2019, 3:25 PM
Lydia_Pintscher triaged this task as High priority.Jul 29 2019, 4:08 PM
Lydia_Pintscher moved this task from Incoming to Ready to estimate on the Wikidata-Campsite board.

Related: T211881: graphoid: Code stewardship request Currently graphoid doesn't have any owner

alaa_wmde updated the task description. (Show Details)Jul 30 2019, 12:07 PM
alaa_wmde moved this task from Ready to estimate to Ready to pick up on the Wikidata-Campsite board.

Change 526442 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/services/graphoid@master] Improve user agent

https://gerrit.wikimedia.org/r/526442

Ladsgroup added subscribers: alaa_wmde, akosiaris.EditedJul 30 2019, 3:37 PM

@Lydia_Pintscher @alaa_wmde So the current user agent of graphoid service is graphoid (yurik at wikimedia). Yurik has left Wikimedia for a couple years I think. I made a patch to fix it but it fails because blubber version 3 is not supported anymore (does it mean we can't merge anything in graphoid right now? @akosiaris knows better)

I looked at hadoop for requests to the query service and couldn't find any request having graphoid mentioned in their UA. Maybe I missed something. Can @Smalyshev double check it against this given UA?

The Graph extension builds the URL but I couldn't find any place that it makes requests but I found that it doesn't hit the internal values, it should be configurable and hit the internal URL in production, that way we can bypass all of these issues plus making it faster by avoiding encryption and TLS handshakes.

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptJul 30 2019, 4:24 PM

So the current user agent of graphoid service is graphoid (yurik at wikimedia)

That should work though. In fact, it's better user agent than many others, even though inaccurate :)

couldn't find any request having graphoid mentioned in their UA.

Hmm this is weird. I will check but in general this would suggest something breaks before it gets to even send the query.

Thanks for checking! I think we achieved the scope of this task, more discussion/investigation should go back to T226250.

@Lydia_Pintscher @alaa_wmde So the current user agent of graphoid service is graphoid (yurik at wikimedia). Yurik has left Wikimedia for a couple years I think. I made a patch to fix it but it fails because blubber version 3 is not supported anymore (does it mean we can't merge anything in graphoid right now? @akosiaris knows better)

It's unmaintained as you pointed out (see T211881 for the glory details). Even if we fixed the blubber file (I am guessing that's where the issue is), deploying anything merged would probably not happen. Plus, there is no one to even review the patches and get them merged right now.

alaa_wmde closed this task as Resolved.Oct 1 2019, 2:48 PM