Page MenuHomePhabricator

WikiEditor insert file dialog broken (due to gadgets that override the open function of file dialog)
Closed, ResolvedPublic

Description

<juancarlos> [14:57:19] juancarlos: Hello! It seems there's a bug on wiktionary.
<juancarlos> [14:57:37] juancarlos: Using the source code editor, try to use the editing toolbar to insert a file.
<juancarlos> [14:58:16] juancarlos: A dialog box opens but no matter the content you type in, it does not insert it into the editing window.
<juancarlos> [15:08:20] juancarlos: (This does not happen on the English Wikipedia)

Seems to have broken in 1.34.0-wmf.17, https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/WikiEditor/+/524635/ is looking like it missed a spot. Will upload a patch soon.

Event Timeline

Krenair created this task.Aug 7 2019, 10:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 7 2019, 10:54 PM

Change 528964 had a related patch set uploaded (by Alex Monk; owner: Alex Monk):
[mediawiki/extensions/WikiEditor@master] Follow-up Ia75d685c: Fix the insert file dialog

https://gerrit.wikimedia.org/r/528964

Change 529075 had a related patch set uploaded (by Krinkle; owner: Alex Monk):
[mediawiki/extensions/WikiEditor@wmf/1.34.0-wmf.17] Follow-up Ia75d685c: Fix the insert file dialog

https://gerrit.wikimedia.org/r/529075

Change 528964 merged by jenkins-bot:
[mediawiki/extensions/WikiEditor@master] Follow-up Ia75d685c: Fix the insert file dialog

https://gerrit.wikimedia.org/r/528964

Change 529075 merged by jenkins-bot:
[mediawiki/extensions/WikiEditor@wmf/1.34.0-wmf.17] Follow-up Ia75d685c: Fix the insert file dialog

https://gerrit.wikimedia.org/r/529075

Mentioned in SAL (#wikimedia-operations) [2019-08-08T23:49:19Z] <urbanecm@deploy1001> Synchronized php-1.34.0-wmf.17/extensions/WikiEditor/modules/jquery.wikiEditor.dialogs.config.js: SWAT: rEWED6dcab39fd13c: Follow-up Ia75d685c: Fix the insert file dialog (T230078) (duration: 00m 50s)

Krenair closed this task as Resolved.Aug 8 2019, 11:52 PM

I see somewhat similar issue in hewiki

It have exception on access to whitespace which is undefined ("pre: whitespace[ 0 ] + '[[',") when pressing on Insert button.

Uncaught TypeError: Cannot read property '0' of undefined
    at HTMLDivElement.wikieditor-toolbar-tool-file-insert (load.php?lang=he&modules=ext.wikiEditor&skin=vector&version=1inccqp:59)
    at HTMLButtonElement.props.click (load.php?lang=he&modules=jquery.ui.autocomplete%2Cbutton%2Ccore%2Cdialog%2Cdraggable%2Cmenu%2Cmouse%2Cposition%2Cresizable%2Cwidget|jquery.ui.core.styles&skin=vector&version=1kvmkqs:33)
    at HTMLButtonElement.dispatch (load.php?lang=he&modules=ext.TemplateWizard%2Ccharinsert%2CeventLogging%2CnavigationTiming%2Cpopups%2CwikimediaEvents|ext.centralNotice.geoIP|ext.centralauth.ForeignApi%2Ccentralautologin|ext.cx.eventlogging.campaigns|ext.quicksurveys.init%2Clib|ext.uls.common%2Ccompactlinks%2Cinit%2Cinterface%2Cpreferences%2Cwebfonts|ext.visualEditor.desktopArticleTarget.init|ext.visualEditor.progressBarWidget%2CsupportCheck%2CtargetLoader%2CtempWikitextEditorWidget%2Ctrack%2Cve|jquery%2Cmoment%2Coojs%2Coojs-router%2Coojs-ui-core%2Coojs-ui-toolbars%2Coojs-ui-widgets%2Coojs-ui-windows|jquery.accessKeyLabel%2CcheckboxShiftClick%2Cclient%2Ccookie%2CgetAttrs%2ChighlightText%2ClengthLimit%2CmakeCollapsible%2Csuggestions%2CtabIndex%2CtextSelection%2Cthrottle-debounce%2Ctipsy|jquery.makeCollapsible.styles|jquery.uls.data|mediawiki.ForeignApi%2CForeignStructuredUpload%2CForeignUpload%2CRegExp%2CString%2CTitle%2CUpload%2CUri%2Capi%2Cbase%2Ccldr%2CconfirmCloseWindow%2Ccookie%2Cexperiments%2Cicon%2CjqueryMsg%2Clanguage%2Cnotify%2CsearchSuggest%2Cstorage%2Ctemplate%2Cuser%2Cutil%2Cviewport%2Cwidgets|mediawiki.ForeignApi.core|mediawiki.ForeignStructuredUpload.BookletLayout|mediawiki.Upload.BookletLayout%2CDialog|mediawiki.action.edit|mediawiki.action.edit.collapsibleFooter%2CeditWarning|mediawiki.language.specialCharacters|mediawiki.libs.jpegmeta%2Cpluralruleparser|mediawiki.page.ready%2Cstartup|mediawiki.template.regexp|mediawiki.ui.button%2Cicon|mediawiki.widgets.CategoryMultiselectWidget%2CDateInputWidget%2CStashedFileWidget%2CUserInputWidget%2CvisibleLengthLimit|mediawiki.widgets.DateInputWidget.styles|mmv.bootstrap%2Chead|mmv.bootstrap.autostart|oojs-ui-toolbars.icons|oojs-ui-widgets.icons|oojs-ui-windows.icons|oojs-ui.styles.icons-content%2Cicons-editing-advanced%2Cicons-editing-citation%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-interactions%2Cicons-media%2Cicons-movement|skins.vector.js|user.defaults|wikibase.client.action.edit.collapsibleFooter&skin=vector&version=1sapcp1:223)
    at HTMLButtonElement.elemData.handle (load.php?lang=he&modules=ext.TemplateWizard%2Ccharinsert%2CeventLogging%2CnavigationTiming%2Cpopups%2CwikimediaEvents|ext.centralNotice.geoIP|ext.centralauth.ForeignApi%2Ccentralautologin|ext.cx.eventlogging.campaigns|ext.quicksurveys.init%2Clib|ext.uls.common%2Ccompactlinks%2Cinit%2Cinterface%2Cpreferences%2Cwebfonts|ext.visualEditor.desktopArticleTarget.init|ext.visualEditor.progressBarWidget%2CsupportCheck%2CtargetLoader%2CtempWikitextEditorWidget%2Ctrack%2Cve|jquery%2Cmoment%2Coojs%2Coojs-router%2Coojs-ui-core%2Coojs-ui-toolbars%2Coojs-ui-widgets%2Coojs-ui-windows|jquery.accessKeyLabel%2CcheckboxShiftClick%2Cclient%2Ccookie%2CgetAttrs%2ChighlightText%2ClengthLimit%2CmakeCollapsible%2Csuggestions%2CtabIndex%2CtextSelection%2Cthrottle-debounce%2Ctipsy|jquery.makeCollapsible.styles|jquery.uls.data|mediawiki.ForeignApi%2CForeignStructuredUpload%2CForeignUpload%2CRegExp%2CString%2CTitle%2CUpload%2CUri%2Capi%2Cbase%2Ccldr%2CconfirmCloseWindow%2Ccookie%2Cexperiments%2Cicon%2CjqueryMsg%2Clanguage%2Cnotify%2CsearchSuggest%2Cstorage%2Ctemplate%2Cuser%2Cutil%2Cviewport%2Cwidgets|mediawiki.ForeignApi.core|mediawiki.ForeignStructuredUpload.BookletLayout|mediawiki.Upload.BookletLayout%2CDialog|mediawiki.action.edit|mediawiki.action.edit.collapsibleFooter%2CeditWarning|mediawiki.language.specialCharacters|mediawiki.libs.jpegmeta%2Cpluralruleparser|mediawiki.page.ready%2Cstartup|mediawiki.template.regexp|mediawiki.ui.button%2Cicon|mediawiki.widgets.CategoryMultiselectWidget%2CDateInputWidget%2CStashedFileWidget%2CUserInputWidget%2CvisibleLengthLimit|mediawiki.widgets.DateInputWidget.styles|mmv.bootstrap%2Chead|mmv.bootstrap.autostart|oojs-ui-toolbars.icons|oojs-ui-widgets.icons|oojs-ui-windows.icons|oojs-ui.styles.icons-content%2Cicons-editing-advanced%2Cicons-editing-citation%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-interactions%2Cicons-media%2Cicons-movement|skins.vector.js|user.defaults|wikibase.client.action.edit.collapsibleFooter&skin=vector&version=1sapcp1:219)

I can reproduce it on he wikipedia/wiktionary/wikibooks as anonymous but can't reproduce it on local installation nor fa/ar wikis

happy5214 moved this task from Backlog to Closed on the WikiEditor board.Aug 27 2019, 1:03 AM
Aklapper renamed this task from WikiEditor insert file dialog broken to WikiEditor insert file dialog broken (due to gadgets that override the open function of file dialog).Sep 12 2019, 11:36 AM