Page MenuHomePhabricator

Search & Replace: Non-regex mode with regex characters like [^ ] fails in IE8
Closed, DeclinedPublic

Description

Author: wikibugs

Description:
Reporting against Babaco Release.

Steps to reproduce::
1)Navigate to a page and click Edit link.
2)Enter following text in the editable text area.
Test[^ ]
3)Click on 'Search and replace' icon.
4)Set "Test[^ ]" for 'search for' text box.
5)Set "Calcey" for 'replace with' text box.
6)Click on 'Replace next' button.
<<Giving the following output
Calcey^ ]

Expected output::
System shall be display the 'Calcey' text.

Test Environment::
Browser (User-Agent): Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)


Version: unspecified
Severity: minor
OS: Windows XP
Platform: PC
URL: http://prototype.wikimedia.org/deployment/

Details

Reference
bz21051

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:51 PM
bzimport set Reference to bz21051.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Oct 8 2009, 7:23 AM

Tweaking summary; cannot reproduce this bug in Firefox 3.0.14

Can't reproduce this in IE8 either, probably fixed at some point.

wikibugs wrote:

Test[^ ] is replaced as TCalcey.

Expected is to replace Test[^ ] with Calcey text.

Re-open the bug

Paladox set Security to None.Dec 10 2015, 9:00 AM
Paladox added a subscriber: Aklapper.
Jdforrester-WMF closed this task as Declined.Apr 29 2016, 3:19 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

MediaWiki no longer supports JavaScript execution on IE8; consequently, I'm Declining this task.

happy5214 moved this task from Backlog to Closed on the WikiEditor board.Aug 4 2019, 12:02 PM