Page MenuHomePhabricator

[mobile] Homepage modules overlays displayed cutoff
Closed, ResolvedPublic

Description

The issue is present with every Homepage mobile overlay - Start, Impact, Mentor. and Help modules. Below is a specific example for Help module.

  1. On a mobile device (or in a browser mobile emulator) go to Homepage and click on "Get help with editing".
  2. The overlay opens with the following element not visible in the viewport (on iPhone it can be scrolled down to view it).
<h3 class="growthexperiments-homepage-module-section growthexperiments-homepage-
module-section-subheader growthexperiments-homepage-module-subheader">Top help pages about editing</h3>

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : wmf/1.34.0-wmf.23Fix broken display of mobile overlay headings
mediawiki/extensions/GrowthExperiments : masterFix broken display of mobile overlay headings

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2019, 9:33 PM

This is a regression caused by T232548, and so we should solve it before deployed T232548.

Etonkovidova renamed this task from [wmf.23] "Top help pages about editing" header not visibleon mobile Help panel overlay to [wmf.23] "Top help pages about editing" header not visible on mobile Help panel overlay .Sep 17 2019, 11:29 PM

@Catrope @kostajh @Tgr @marcella @Etonkovidova -- I was just playing with this, and it looks to me like it extends to all modules, not just the help module. If that's the case, I think this is a high-priority bug fix, because it means that all mobile users can't see the top of any homepage modules once they open them.

@Etonkovidova -- can you confirm?

Etonkovidova renamed this task from [wmf.23] "Top help pages about editing" header not visible on mobile Help panel overlay to [mobile] Homepage modules overlays displayed cutoff .Sep 23 2019, 10:49 PM
Etonkovidova removed a project: Regression.
Etonkovidova updated the task description. (Show Details)

This appears to be a regression in MinervaNeue between wmf.22 and wmf.23.

This happened because the change above moved the padding to make room for the header from the overlay div to the overlay-content div, and Special:Homepage already had a different padding rule on overlay-content, which overrode Minerva's new rule.

Change 538723 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Fix broken display of mobile overlay headings

https://gerrit.wikimedia.org/r/538723

Change 538788 had a related patch set uploaded (by Kosta Harlan; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.23] Fix broken display of mobile overlay headings

https://gerrit.wikimedia.org/r/538788

Change 538723 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Fix broken display of mobile overlay headings

https://gerrit.wikimedia.org/r/538723

Change 538788 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.23] Fix broken display of mobile overlay headings

https://gerrit.wikimedia.org/r/538788

Mentioned in SAL (#wikimedia-operations) [2019-09-24T11:24:35Z] <urbanecm@deploy1001> Synchronized php-1.34.0-wmf.23/extensions/GrowthExperiments/modules/homepage/ext.growthExperiments.Homepage.less: SWAT: d4c64a7: Fix broken display of mobile overlay headings (T233163) (duration: 00m 57s)

@MMiller_WMF - the fix is in place; I checked in betalabs and will check after deployment (it should be backported to wmf.23).

MMiller_WMF closed this task as Resolved.Sep 24 2019, 5:09 PM

Thank you for the quick fix @Catrope @kostajh @Etonkovidova! This looks good to me in production.