Page MenuHomePhabricator

PHP Notice: Undefined property: stdClass::$page_namespace
Closed, ResolvedPublic

Description

Error

MediaWiki version: 1.35.0-wmf.1

message
PHP Notice: Undefined property: stdClass::$page_namespace

Notes

  • Appears to be a new regression in 1.35.0-wmf.1.
  • 355 reports in the last hour alone (or ~60% of production MW errors)

Details

Request ID
XaFZKwpAEDYAAFtfVvQAAABM
Request URL
/w/api.php?action=query&prop=linkshere&lhprop=pageid&lhnamespace=0&lhlimit=10&pageids=333424&format=json
Stack Trace
exception.trace
#0 /includes/api/ApiQueryBase.php(596): MWExceptionHandler::handleError(integer, string, string, integer, array)
#1 /includes/api/ApiQueryBacklinksprop.php(289): ApiQueryBase->executeGenderCacheFromResultWrapper(Wikimedia\Rdbms\ResultWrapper, string)
#2 /includes/api/ApiQueryBacklinksprop.php(83): ApiQueryBacklinksprop->run()
#3 /includes/api/ApiQuery.php(255): ApiQueryBacklinksprop->execute()
#4 /includes/api/ApiMain.php(1588): ApiQuery->execute()
#5 /includes/api/ApiMain.php(537): ApiMain->executeAction()
#6 /includes/api/ApiMain.php(508): ApiMain->executeActionWithErrorHandling()
#7 /api.php(83): ApiMain->execute()
#8 /srv/mediawiki/w/api.php(3): require(string)
#9 {main}
Related Gerrit Patches:

Event Timeline

Krinkle created this task.Oct 12 2019, 4:46 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 12 2019, 4:46 AM
Krinkle updated the task description. (Show Details)Oct 12 2019, 4:48 AM

Change 542663 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/core@master] Run executeGenderCacheFromResultWrapper with titles in prop=linkshere

https://gerrit.wikimedia.org/r/542663

Umherirrender triaged this task as High priority.

lhprop=pageid skipps the addition of necessary fields to the result set, added a condition for that

Krinkle added subscribers: CDanis, Reedy.

Reverting out of 1.35.0-wmf.1 (for now), due to ~240K errors in 90 minutes on enwiki

Change 542687 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.1] Revert "Fill GenderCache for used pages in action=query&prop=fileusage"
https://gerrit.wikimedia.org/r/542687

Change 542686 had a related patch set uploaded (by Krinkle; owner: Reedy):
[mediawiki/core@master] Revert "Fill GenderCache for used pages in action=query&prop=fileusage"

https://gerrit.wikimedia.org/r/542686

Reverted out of wmf.1 locally. Before wmf.2 is branched, it should either be fixed or reverted in master as well. Tagging as blocker to remember that.

Change 542917 had a related patch set uploaded (by Reedy; owner: Umherirrender):
[mediawiki/core@REL1_34] Run executeGenderCacheFromResultWrapper with titles in prop=linkshere

https://gerrit.wikimedia.org/r/542917

Change 542663 merged by jenkins-bot:
[mediawiki/core@master] Run executeGenderCacheFromResultWrapper with titles in prop=linkshere

https://gerrit.wikimedia.org/r/542663

Change 542917 merged by jenkins-bot:
[mediawiki/core@REL1_34] Run executeGenderCacheFromResultWrapper with titles in prop=linkshere

https://gerrit.wikimedia.org/r/542917

Reedy closed this task as Resolved.Oct 14 2019, 2:02 PM

Change 542686 abandoned by Reedy:
Revert "Fill GenderCache for used pages in action=query&prop=fileusage"

Reason:
No longer needed, fix patch is merged

https://gerrit.wikimedia.org/r/542686