Page MenuHomePhabricator

Show tpt-duplicate error message only once for a translation unit
Closed, ResolvedPublic

Description

When marking a page for translation, if a translation unit is repeated twice, the error message also appears twice. This can be avoided.

See screenshot below,

Event Timeline

abi_ created this task.Oct 22 2019, 12:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 22 2019, 12:43 PM
abi_ triaged this task as Low priority.Oct 22 2019, 12:44 PM
abi_ moved this task from Backlog to tux on the MediaWiki-extensions-Translate board.
Urbanecm added a subscriber: Urbanecm.

Moving to appropriate column then!

Pppery claimed this task.Dec 5 2019, 2:34 AM
Pppery added a subscriber: Pppery.

This feels like it was almost too easy for a GCI task, given how little time it took me to code.

Reedy added a subscriber: Reedy.Dec 5 2019, 2:39 AM

This feels like it was almost too easy for a GCI task, given how little time it took me to code.

Many people have different skill levels. So there will be tasks that are easy for some, and harder for others

Change 554665 had a related patch set uploaded (by Pppery; owner: Pppery):
[mediawiki/extensions/Translate@master] Prevent duplicate translation unit error from showing twice

https://gerrit.wikimedia.org/r/554665

Pppery added a comment.Dec 5 2019, 3:10 AM

The actual behavior I noticed and wrote a patch to fix was that the error message shows up twice if you use the same translation unit name three times in one page. It is possible that there is some other cause for this duplicate error message that I was unable to reproduce and this patch may not fix.

Nikerabbit closed this task as Resolved.Dec 16 2019, 10:14 AM
Nikerabbit removed a project: Patch-For-Review.

Change 554665 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Prevent duplicate translation unit error from showing twice

https://gerrit.wikimedia.org/r/554665