Page MenuHomePhabricator

Implement get language links endpoint
Closed, ResolvedPublic2 Estimated Story Points

Description

Description
This endpoint should return a list of all available alternative language versions for a given page as outlined in T230846

Requirements

  • Implement endpoint described by T230846
  • Add integration test covering expected behaviour - delayed until T236680 is deployed
  • Add documentation for endpoint (reviewed via email)

Event Timeline

WDoranWMF triaged this task as Medium priority.Oct 22 2019, 2:28 PM
WDoranWMF created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 22 2019, 2:28 PM
Pchelolo added a subscriber: Pchelolo.EditedOct 22 2019, 8:32 PM

The subtask relationship of this task is wrong.

Pchelolo claimed this task.Nov 5 2019, 7:14 PM
Pchelolo moved this task from Ready to Doing on the Platform Team Workboards (Green) board.

Change 548860 had a related patch set uploaded (by Will Doran; owner: Ppchelko):
[mediawiki/core@master] REST: Introduce language links endpoint.

https://gerrit.wikimedia.org/r/548860

Pchelolo updated the task description. (Show Details)

Change 563298 had a related patch set uploaded (by Ppchelko; owner: Ppchelko):
[mediawiki/core@master] Add integration tests for /page/{title}/links/language endpoint.

https://gerrit.wikimedia.org/r/563298

So, the endpoint is live; I've validated that it's working correctly. Please close this when the tests are merged.

WDoranWMF removed Pchelolo as the assignee of this task.Mar 4 2020, 8:03 PM
WDoranWMF moved this task from Blocked to Ready on the Platform Team Workboards (Green) board.
daniel claimed this task.Mar 16 2020, 3:46 PM

Add integration test covering expected behaviour - delayed until T236680 is deployed

A full end-to-end test based on a vanilla install is not possible for this feature, because per default, no language link prefixes are configured (a vanilla install has no sibling projects). An end-to-end test could be written against our live config, but as far as I know, we don't have a setup for that in CI yet. We also can't yet run end-to-end tests against beta, because this requires shared secrets for login.

The best we can do right now is a phpunit-based integration test, like the ones we traditionally write for the action API.

Change 580098 had a related patch set uploaded (by Daniel Kinzler; owner: Daniel Kinzler):
[mediawiki/core@master] CompareHandler: add phpunit integration test

https://gerrit.wikimedia.org/r/580098

daniel set the point value for this task to 2.Mar 25 2020, 6:49 PM

Change 580098 merged by jenkins-bot:
[mediawiki/core@master] LanguageLinksHandler: add phpunit integration test

https://gerrit.wikimedia.org/r/580098

Change 563298 abandoned by Ppchelko:
Add integration tests for /page/{title}/links/language endpoint.

https://gerrit.wikimedia.org/r/563298

apaskulin updated the task description. (Show Details)Mar 27 2020, 7:52 PM
Naike added a subscriber: Naike.Jun 5 2020, 3:39 PM

@daniel is this ticket ready for @eprodromou to sign-off?

Naike reassigned this task from daniel to eprodromou.Aug 14 2020, 10:21 AM
Naike added a subscriber: daniel.
eprodromou closed this task as Resolved.Wed, Sep 16, 2:56 PM