Page MenuHomePhabricator

SingleEntitySourceServices PrefetchingTermLookup should use new terms storage
Closed, ResolvedPublic

Description

Highlighted in T232040#5774510

Event Timeline

Addshore created this task.Jan 7 2020, 11:18 AM
Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptJan 7 2020, 11:18 AM

Change 562320 had a related patch set uploaded (by Addshore; owner: Sarhan):
[mediawiki/extensions/Wikibase@master] Update SingleEntitySourceServices to respect item terms migration stages

https://gerrit.wikimedia.org/r/562320

Addshore claimed this task.Jan 7 2020, 11:48 AM
Restricted Application added a project: User-Addshore. ยท View Herald TranscriptJan 7 2020, 11:48 AM

I don't want to mess with the WIP patch but I want to mention that the patch at its current state removes usage of BufferingTermLookup, this caching layer is widely needed and if you look at the numbers in grafana, 62% of requests only hit this caching layer (it used to be higher IIRC). Given that the new term store will have slower reads (which is by design) I think we should keep this caching layer.

Maintenance_bot moved this task from incoming to in progress on the Wikidata board.Jan 7 2020, 2:15 PM

Change 562548 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/Wikibase@master] wb_terms, delete unused MultiTermStoreWriter

https://gerrit.wikimedia.org/r/562548

Change 562548 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] wb_terms, delete unused MultiTermStoreWriter

https://gerrit.wikimedia.org/r/562548

I don't want to mess with the WIP patch but I want to mention that the patch at its current state removes usage of BufferingTermLookup, this caching layer is widely needed and if you look at the numbers in grafana, 62% of requests only hit this caching layer (it used to be higher IIRC). Given that the new term store will have slower reads (which is by design) I think we should keep this caching layer.

Never mind, apparently PrefetchingPropertyTermLookup has the caching layer as $terms attribute. I think it's fine (unless it doesn't work as intended which I hope not.)

Change 563204 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/Wikibase@master] Update SingleEntitySourceServices to respect item terms migration stages

https://gerrit.wikimedia.org/r/563204

Change 563204 abandoned by Addshore:
Update SingleEntitySourceServices to respect item terms migration stages

https://gerrit.wikimedia.org/r/563204

Change 563227 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/WikibaseMediaInfo@master] Use new namespace for PrefetchingTermLookup

https://gerrit.wikimedia.org/r/563227

Change 562320 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] wbterms: Update SingleEntitySourceServices PrefetchingTermLookup

https://gerrit.wikimedia.org/r/562320

Change 563227 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Use new namespace for PrefetchingTermLookup

https://gerrit.wikimedia.org/r/563227

Change 563958 had a related patch set uploaded (by Ladsgroup; owner: Addshore):
[mediawiki/extensions/Wikibase@wmf/1.35.0-wmf.14] wbterms: Update SingleEntitySourceServices PrefetchingTermLookup

https://gerrit.wikimedia.org/r/563958

Addshore triaged this task as Medium priority.Jan 14 2020, 9:54 AM

Change 563958 abandoned by Addshore:
wbterms: Update SingleEntitySourceServices PrefetchingTermLookup

Reason:
Abandoning as I figure we are not backporting this!

https://gerrit.wikimedia.org/r/563958

Addshore closed this task as Resolved.Jan 15 2020, 5:08 PM