Page MenuHomePhabricator

Page titles don't update after move unless manually purged
Closed, ResolvedPublic

Description

After moving a page, the old cached page title is displayed until the cache has been purged or a null edit has been made. The problem was first seen on Saturday, March 29.

Steps to reproduce:

Problem behaviour has been identified on:

  • testwiki, eswiki, plwiki, iswiki, MediaWiki.org

Problem is not present on:

  • enwiki

The problem happens whether you select "Leave a redirect behind" or not.
The problem is not related to FlaggedRevs as iswiki does not have that feature.

Original post by XanaG:

Since yesterday, I have noticed that renaming pages does not fully work: the history moves, and the associated discussion page has the correct name; the page url also shows the correct name, but the displayed title is the old one. Check , eg,
[[:es:Parque_natural_de_Babia_y_Luna]], [[:es:Nocardia]] or [[:es:MEO (operadora)]].

Event Timeline

XanaG created this task.Mar 29 2020, 3:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 29 2020, 3:02 PM
XanaG added a comment.Mar 29 2020, 3:23 PM

One more detail: If I edit the page with the incorrect (old) name and I save it, the showed name becomes the correct new one.

Hi @XanaG, thanks for taking the time to report this and welcome to Wikimedia Phabricator! Unfortunately this Wikimedia Phabricator task lacks some information. If you have time and can still reproduce the situation: Please add a more complete description to this task. That should include

  • a clear list of exact steps to reproduce the situation, step by step, so that nobody needs to guess or interpret how you performed each step,
  • what happens after performing these steps to reproduce,
  • what you expected to happen instead,
  • a full link to a web address where the issue can be seen.

You can edit the task description by clicking Edit Task. Ideally, a good description should allow any other person to follow these steps (without having to interpret steps) and see the same results. Problems that others can reproduce can get fixed faster. Thanks!

XanaG added a comment.Mar 29 2020, 3:50 PM

Go to
https://es.wikipedia.org/w/index.php?title=Usuaria:XanaG/Notas2
From the "Más" drop-down menu, select " Trasladar"
In the form, give Título nuevo: XanaG/Notas3
and click "Trasladar la página"
In the next page, where it says 'La página «Usuaria:XanaG/Notas2» ha sido trasladada a «Usuaria:XanaG/Notas3»', click on Usuaria:XanaG/Notas3
The page url is https://es.wikipedia.org/wiki/Usuaria:XanaG/Notas3
The displayed page title is Usuaria:XanaG/Notas2

The page url is https://es.wikipedia.org/wiki/Usuaria:XanaG/Notas3

That page never existed: https://es.wikipedia.org/w/index.php?title=Especial:Registro&page=Usuaria%3AXanaG%2FNotas3

So your steps to reproduce seem incorrect.

The displayed page title is Usuaria:XanaG/Notas2

I cannot reproduce the problem on https://www.mediawiki.org/wiki/User:AKlapper_(WMF)/Sandbox/T248789-02 after moving that page from https://www.mediawiki.org/wiki/User:AKlapper_(WMF)/Sandbox/T248789-01 - it shows the correct page title.

However, I see on https://es.wikipedia.org/w/index.php?title=Especial:Registro&page=Usuaria%3AXanaG%2FNotas1 that "XanaG trasladó la página Usuaria:XanaG/Notas1 a Usuaria:XanaG/Notas2" (moved page Usuaria:XanaG/Notas1 to Usuaria:XanaG/Notas2)
And you are right, https://es.wikipedia.org/w/index.php?title=Usuaria:XanaG/Notas2 has Usuaria:XanaG/Notas1 as its title.

Did you "Leave a redirect behind" ("Dejar una redirección"), or not?
Asking because of T246720#6008539 (but I don't understand on which wikis FlaggedRevs is deployed).

XanaG added a comment.Mar 30 2020, 7:33 AM

Hi,
Yes, https://es.wikipedia.org/wiki/Usuaria:XanaG/Notas3 does not exist on purpose. I thought that, if it did, you could not reproduce the problem exactly as I indicated, since you would then have to remove Notas3 to be able to move Notas2.

But yes, you can also see the problem in the pages registers.

In all cases I have seen, there was a redirect left behind. The redirect works fine. It does not make a difference whether one later deletes the redirected page or not.

The last significant (maybe helpful?) observation is that, if you edit the new page after moving it, the title will be correct. Ie, if you edit https://es.wikipedia.org/wiki/Usuaria:XanaG/Notas3 after doing the previous steps, and save the edit, the displayed title will be Usuaria:XanaG/Notas3 (matching the URL)

And,

Ah, that makes sense! Thanks for explaining and sorry that I got a bit confused at first. :)

Also seen on pl.wp when this page was moved: https://pl.wikipedia.org/w/index.php?title=Wikipedysta:Aleksander_Kadij/Cerkiew_w_Potoku_Górnym&action=history (it is now fixed after the page was edited)

Ammarpad renamed this task from 'Move page' does not change the displayed page name in es.wikipedia to Page titles don't update after move unless manually purged.Apr 1 2020, 10:50 AM
Ammarpad added a project: Regression.
Ammarpad added a subscriber: Thjarkur.

I'm seeing this happen on MediaWiki.org, test.wikipedia.org, and the Icelandic Wikipedia, but not the English Wikipedia.

The cached page title is displayed both on the page itself and its talk page until the page is manually purged.

Thjarkur updated the task description. (Show Details)Apr 1 2020, 11:27 AM
Aklapper triaged this task as Unbreak Now! priority.Apr 1 2020, 11:33 AM

Adding CPT Clinic Duty. (If this is not the right CPT tag, then please edit the quite short tag description what people are supposed to tag.)

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptApr 1 2020, 11:33 AM
Anomie added a subscriber: Anomie.Apr 2 2020, 3:19 PM

Adding CPT Clinic Duty. (If this is not the right CPT tag, then please edit the quite short tag description what people are supposed to tag.)

It's not, tasks should go into the inbox column on Core Platform Team. I've edited the tag description to specify that.

Change 585532 had a related patch set uploaded (by Anomie; owner: Anomie):
[mediawiki/core@master] MovePage: Use correct Title when creating the null revision

https://gerrit.wikimedia.org/r/585532

Change 585532 merged by jenkins-bot:
[mediawiki/core@master] MovePage: Use correct Title when creating the null revision

https://gerrit.wikimedia.org/r/585532

Anomie added a comment.Apr 2 2020, 5:25 PM

This is currently marked "UBN!", so that would suggest yes. This bug seems to exist in both wmf.25 and wmf.26.

This is currently marked "UBN!", so that would suggest yes.

That is correct. Hence my question implicitly being "do people really think this is UBN?".

Change 585578 had a related patch set uploaded (by Jforrester; owner: Anomie):
[mediawiki/core@wmf/1.35.0-wmf.26] MovePage: Use correct Title when creating the null revision

https://gerrit.wikimedia.org/r/585578

Change 585578 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.26] MovePage: Use correct Title when creating the null revision

https://gerrit.wikimedia.org/r/585578

Mentioned in SAL (#wikimedia-operations) [2020-04-02T19:35:27Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.26/includes/MovePage.php: T248789 MovePage: Use correct Title when creating the null revision (duration: 00m 59s)

Jdforrester-WMF closed this task as Resolved.Apr 2 2020, 7:37 PM

Deployed. Thanks!