Page MenuHomePhabricator

The username suggestion list appears outside the Reply tool's text input area in RTL
Closed, ResolvedPublic

Description

Testing the tool on Arabic Wikipedia, something strange is happening when I tried to ping someone using @: the suggestion list is outside the box and in the wrong side.

I had to zoom out a little bit to read the list.

Event Timeline

ppelberg created this task.Jun 1 2020, 1:35 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 1 2020, 1:35 AM

Change 601432 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[VisualEditor/VisualEditor@master] ve.ui.CompletionWidget: Fix positioning in RTL

https://gerrit.wikimedia.org/r/601432

matmarex added a comment.EditedJun 1 2020, 9:11 PM

You might find it interesting that when measuring the position of some text on screen, the 'right' property refers to "the right coordinate" (or in other words, position of the right edge relative to the left edge of the container), but when defining the position of some element in CSS, the 'right' property refers to "the distance between the element's right edge and the right edge of its containing block" (or in other words, position of the right edge relative to the right edge of the container).

This bug is caused by confusing the two when trying to align the right edge of the suggestion popup with the right edge of the text you typed ;)

Esanders added a project: Editing QA.
Esanders moved this task from Inbox to High Priority on the Editing QA board.

Change 601432 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] ve.ui.CompletionWidget: Fix positioning in RTL

https://gerrit.wikimedia.org/r/601432

Change 602180 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (b7f83c6ba)

https://gerrit.wikimedia.org/r/602180

Change 602180 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (b7f83c6ba)

https://gerrit.wikimedia.org/r/602180

matmarex renamed this task from The username suggestion list appears outside the Reply tool's text input area to The username suggestion list appears outside the Reply tool's text input area in RTL.Jun 4 2020, 11:36 AM
Ryasmeen edited projects, added Verified; removed Editing QA.Jun 5 2020, 8:36 PM
ppelberg closed this task as Resolved.Jun 5 2020, 11:35 PM