Page MenuHomePhabricator

Switching from source to visual with a reference leads to lots of things breaking
Closed, ResolvedPublic

Description

We aren't loading the plugin code from Cite, so the reference is treated as a link, and we don't handle the auto-generated ref list well.

Expected behaviour:

  • Type foo <ref>bar</ref> in source mode
  • Switch to visual, you should have a reference and a reference list (auto-generated)
  • Switch back to source, you should have a reference and a reference list

Event Timeline

Esanders created this task.Jun 24 2020, 6:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 24 2020, 6:08 PM

Change 607583 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] Load VisualEditor plugin modules with ReplyWidgetVisual

https://gerrit.wikimedia.org/r/607583

Change 607584 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] Allow non-lists to be passed to unwrapList

https://gerrit.wikimedia.org/r/607584

Change 607583 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Load VisualEditor plugin modules with ReplyWidgetVisual

https://gerrit.wikimedia.org/r/607583

Change 607584 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Allow non-lists to be passed to unwrapList

https://gerrit.wikimedia.org/r/607584

matmarex moved this task from Code Review to QA on the Editing-team (Q3 2019-2020 Kanban Board) board.
matmarex added a project: Editing QA.
matmarex added a subscriber: matmarex.

I noticed an interesting problem when testing the patches, filed as T256324 since I think that's out of scope of this task.

ppelberg closed this task as Resolved.Jul 9 2020, 2:46 AM