Page MenuHomePhabricator

Create Wikipedia Ladin
Closed, ResolvedPublic

Description

The language committee has approved the creation of Wikipedia Ladin.

  • Local file uploads: disabled

Thank you.


Pre-install automatic checklist:

The Wiki is ready to be created.


Post install automatic checklist:


Step by step commands:
On deploy1001:
cd /srv/mediawiki-staging/
git fetch
git log -p HEAD..@{u}
git rebase
On mwmaint1002:
scap pull
mwscript extensions/WikimediaMaintenance/addWiki.php --wiki=muswiki lld wikipedia lldwiki lld.wikipedia.org
On deploy1001:
scap sync-file wmf-config/db-eqiad.php "Creating lldwiki (T259432)"
scap sync-file wmf-config/db-codfw.php "Creating lldwiki (T259432)"
scap sync-file dblists "Creating lldwiki (T259432)"
scap sync-wikiversions "Creating lldwiki (T259432)"
scap sync-file static/images/project-logos/ "Creating lldwiki (T259432)"
scap sync-file wmf-config/InitialiseSettings.php "Creating lldwiki (T259432)"
scap sync-file langlist "Creating lldwiki (T259432)"
scap update-interwiki-cache

End of automatic output

Event Timeline

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptAug 2 2020, 3:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm triaged this task as Low priority.Aug 2 2020, 4:10 PM
Urbanecm claimed this task.Aug 2 2020, 4:12 PM

Change 617860 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/dns@master] Add lld to langlist helper

https://gerrit.wikimedia.org/r/617860

Change 617861 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] [WIP] Initial configuration for lijwiki

https://gerrit.wikimedia.org/r/617861

Urbanecm updated the task description. (Show Details)Aug 2 2020, 4:39 PM
Urbanecm updated the task description. (Show Details)Aug 2 2020, 4:41 PM

@Urbanecm Your changes will be overriden by the bot in the next couple of hours, Can you make a pull request to fix it?

Urbanecm updated the task description. (Show Details)Aug 2 2020, 4:42 PM
Urbanecm updated the task description. (Show Details)Aug 2 2020, 4:43 PM
Urbanecm updated the task description. (Show Details)
Urbanecm updated the task description. (Show Details)Aug 2 2020, 4:44 PM
Urbanecm updated the task description. (Show Details)Aug 2 2020, 4:44 PM

@Urbanecm Your changes will be overriden by the bot in the next couple of hours, Can you make a pull request to fix it?

Yeah, I know :-). I'm actually locally-running your bot :-).

Change 617862 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMessages@master] Add messages for lldwiki

https://gerrit.wikimedia.org/r/617862

Change 617862 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Add messages for lldwiki

https://gerrit.wikimedia.org/r/617862

Meno25 added a subscriber: Meno25.Aug 3 2020, 4:17 PM

Change 617860 merged by Dzahn:
[operations/dns@master] Add lld to langlist helper

https://gerrit.wikimedia.org/r/617860

MF-Warburg updated the task description. (Show Details)Aug 6 2020, 9:41 PM
Urbanecm updated the task description. (Show Details)Aug 7 2020, 4:46 PM

Shard updated per T259436#6354593.

T259004 should be completed on Tuesday, this wiki will be fully ready to be created later this week.

Urbanecm updated the task description. (Show Details)Aug 11 2020, 9:21 AM
Urbanecm updated the task description. (Show Details)

The wiki is scheduled to be created on Monday, August 17 2020.

Tmv added a subscriber: Tmv.Aug 15 2020, 7:42 AM

@Ladsgroup I saw you closed the above task as Invalid. You should probably close as a duplicate of T259436 instead incase somebody accidentally comes across it

Change 617861 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for lijwiki

https://gerrit.wikimedia.org/r/617861

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:20:40Z] <urbanecm@deploy1001> Synchronized wmf-config/db-eqiad.php: Creating lldwiki (T259432) (duration: 00m 55s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:22:24Z] <urbanecm@deploy1001> Synchronized wmf-config/db-codfw.php: Creating lldwiki (T259432) (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:23:25Z] <urbanecm@deploy1001> Synchronized dblists: Creating lldwiki (T259432) (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:25:12Z] <urbanecm@deploy1001> rebuilt and synchronized wikiversions files: Creating lldwiki (T259432)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:26:53Z] <urbanecm@deploy1001> Synchronized static/images/project-logos/: Creating lldwiki (T259432) (duration: 00m 53s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:27:04Z] <urbanecm@deploy1001> sync-file aborted: Creating lldwiki (T259432)¨ (duration: 00m 00s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:28:04Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Creating lldwiki (T259432) (duration: 00m 55s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:29:09Z] <urbanecm@deploy1001> Synchronized langlist: Creating lldwiki (T259432) (duration: 00m 54s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T13:58:14Z] <Amir1> start of foreachwikiindblist wikidataclient extensions/Wikibase/lib/maintenance/populateSitesTable.php --force-protocol https (T259432)

The logo of the wiki seems to be the enwiki logo rather than the logo linked in the description

jhsoby updated the task description. (Show Details)Aug 17 2020, 3:05 PM
jhsoby added a subscriber: jhsoby.

Import done!

Change 620743 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Add logo files for lldwiki

https://gerrit.wikimedia.org/r/620743

Change 620744 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Change logo for lldwiki to match the requested one

https://gerrit.wikimedia.org/r/620744

Evrifaessa updated the task description. (Show Details)Aug 17 2020, 4:56 PM

Change 620743 merged by jenkins-bot:
[operations/mediawiki-config@master] Add logo files for lldwiki

https://gerrit.wikimedia.org/r/620743

Change 620744 merged by jenkins-bot:
[operations/mediawiki-config@master] Change logo for lldwiki to match the requested one

https://gerrit.wikimedia.org/r/620744

Mentioned in SAL (#wikimedia-operations) [2020-08-17T18:04:35Z] <urbanecm@deploy1001> Synchronized static/images/project-logos/: 67e8f886cd1a9cd2b63ed69761bec6c52889a5b6: Add logo files for lldwiki (T259432) (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2020-08-17T18:08:36Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: 808c17d28c5ebf5ed75f70c224d66129eb2edcd8: Change logo for lldwiki to match the requested one (T259432) (duration: 00m 56s)

The logo of the wiki seems to be the enwiki logo rather than the logo linked in the description

Fixed.

Urbanecm closed this task as Resolved.Aug 17 2020, 6:14 PM

Closing, as the wiki is up.

Meno25 removed a subscriber: Meno25.Aug 18 2020, 3:07 PM