Page MenuHomePhabricator

Revision-delete edits does not show successful operation
Closed, ResolvedPublicBUG REPORT

Description

As a Wikidata Admin, when I click the RevisionDelete button to remove an entry from a page's history I do not get feedback whether the operation failed or succeeded, but when I press the button again I do get an error message that the revision has already been deleted.

I would like to see some indication of a successful operation when I use the RevisionDelete button on Wikidata on the first click.

See report on Wikidata:Contact the development team#Revision-deletion result.

Event Timeline

Just to clarify that the problem is the absence of any notification that the revdel was successful. (The error message when I click again is quite expected).

I just tried it out and got a proper success message (“Revision visibility updated.”) on both Test and real Wikidata. (Unless you mean a different kind of revision deletion?)

Original video files if you want to jump around / have video controls instead of just waiting for the GIF to repeat (the Wikidata test took quite a while to load):

Browsers used by Ymblanter when encountering the issue: Firefox last version (on Linux Manjara) and possibly Palemoon last version (Windows 7). Could we try to reproduce on these specific systems?

Hey @Pyfisch @matej_suchanek Are you performing revision-delete edits, and did you encounter the same issue? Thanks :)

No, sorry, I had no opportunity. But I can try to reproduce it in the sandbox if you wish.

@Lea_Lacroix_WMDE I don't have the revision-delete permission and never had it.

Browsers used by Ymblanter when encountering the issue: Firefox last version (on Linux Manjara) and possibly Palemoon last version (Windows 7). Could we try to reproduce on these specific systems?

FWIW, my tests (see GIFs above) were on Firefox on Ubuntu Linux.

Notifications are now working, as per the discussion Wikidata:Contact the development team#Revision-deletion result.

Will reopen if the issue is encountered again.