Page MenuHomePhabricator

`Fatal exception of type "RuntimeException" ` when voting
Closed, ResolvedPublicPRODUCTION ERROR

Description

When voting in the ArbCom elections, an error message is returned:

Fatal exception of type "RuntimeException"

Details

Stack Trace
2020-11-24 00:08:55 [07c581f4-1420-4dbf-9ea9-541cb6b30029] mw1320 votewiki 1.36.0-wmf.18 exception ERROR: [07c581f4-1420-4dbf-9ea9-541cb6b30029] /w/index.php?title=Special:SecurePoll/vote/808&action=vote   RuntimeException from line 66 of /srv/mediawiki/php-1.36.0-wmf.18/includes/shell/FirejailCommand.php: FirejailCommand does not support parameters that start with --output {"exception_id":"07c581f4-1420-4dbf-9ea9-541cb6b30029","exception_url":"/w/index.php?title=Special:SecurePoll/vote/808&action=vote","caught_by":"entrypoint"} 
[Exception RuntimeException] (/srv/mediawiki/php-1.36.0-wmf.18/includes/shell/FirejailCommand.php:66) FirejailCommand does not support parameters that start with --output
  #0 /srv/mediawiki/php-1.36.0-wmf.18/includes/shell/Shell.php(129): MediaWiki\Shell\FirejailCommand->params(array)
  #1 /srv/mediawiki/php-1.36.0-wmf.18/extensions/SecurePoll/includes/Crypt/GpgCrypt.php(232): MediaWiki\Shell\Shell::command(array)
  #2 /srv/mediawiki/php-1.36.0-wmf.18/extensions/SecurePoll/includes/Crypt/GpgCrypt.php(290): MediaWiki\Extensions\SecurePoll\Crypt\GpgCrypt->runGpg(string, string, string, string, string, string, string, string, string, string, string, string)
  #3 /srv/mediawiki/php-1.36.0-wmf.18/extensions/SecurePoll/includes/Pages/VotePage.php(183): MediaWiki\Extensions\SecurePoll\Crypt\GpgCrypt->encrypt(string)
  #4 /srv/mediawiki/php-1.36.0-wmf.18/extensions/SecurePoll/includes/Pages/VotePage.php(165): MediaWiki\Extensions\SecurePoll\Pages\VotePage->logVote(string)
  #5 /srv/mediawiki/php-1.36.0-wmf.18/extensions/SecurePoll/includes/Pages/VotePage.php(113): MediaWiki\Extensions\SecurePoll\Pages\VotePage->doSubmit()
  #6 /srv/mediawiki/php-1.36.0-wmf.18/extensions/SecurePoll/includes/SpecialSecurePoll.php(87): MediaWiki\Extensions\SecurePoll\Pages\VotePage->execute(array)
  #7 /srv/mediawiki/php-1.36.0-wmf.18/includes/specialpage/SpecialPage.php(607): MediaWiki\Extensions\SecurePoll\SpecialSecurePoll->execute(string)
  #8 /srv/mediawiki/php-1.36.0-wmf.18/includes/specialpage/SpecialPageFactory.php(1188): SpecialPage->run(string)
  #9 /srv/mediawiki/php-1.36.0-wmf.18/includes/MediaWiki.php(310): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
  #10 /srv/mediawiki/php-1.36.0-wmf.18/includes/MediaWiki.php(945): MediaWiki->performRequest()
  #11 /srv/mediawiki/php-1.36.0-wmf.18/includes/MediaWiki.php(548): MediaWiki->main()
  #12 /srv/mediawiki/php-1.36.0-wmf.18/index.php(53): MediaWiki->run()
  #13 /srv/mediawiki/php-1.36.0-wmf.18/index.php(46): wfIndexMain()
  #14 /srv/mediawiki/w/index.php(3): require(string)
  #15 {main}

Event Timeline

jrbs created this task.Nov 24 2020, 12:05 AM
Restricted Application added a project: Platform Engineering. · View Herald TranscriptNov 24 2020, 12:06 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
jrbs triaged this task as Unbreak Now! priority.Nov 24 2020, 12:06 AM
jrbs added a project: Trust-and-Safety.

Boldly bumping to unbreak now! since it's impacting the active ArbCom elections

L235 added a subscriber: L235.Nov 24 2020, 12:07 AM
Reedy changed the subtype of this task from "Task" to "Production Error".Nov 24 2020, 12:10 AM
Urbanecm added a subscriber: Urbanecm.EditedNov 24 2020, 12:13 AM

because fawiki vote wasn't encrypted with gpg, and firejail is only invoked with gpg

Change 643106 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/SecurePoll@master] Do not use gpg --output, use -o instead

https://gerrit.wikimedia.org/r/643106

Change 643107 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/SecurePoll@master] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/643107

Change 642860 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/SecurePoll@wmf/1.36.0-wmf.18] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642860

Change 643106 abandoned by Urbanecm:
[mediawiki/extensions/SecurePoll@master] Do not use gpg --output, use -o instead

Reason:
dupe of I20cac2688bd3514273d7d54ee59cc60bfe55e9e7

https://gerrit.wikimedia.org/r/643106

Change 642861 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/SecurePoll@REL1_35] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642861

Change 642862 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/SecurePoll@REL1_34] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642862

Change 642863 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/SecurePoll@REL1_31] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642863

Change 642860 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@wmf/1.36.0-wmf.18] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642860

SQL added a subscriber: SQL.Nov 24 2020, 12:27 AM

Mentioned in SAL (#wikimedia-operations) [2020-11-24T00:29:00Z] <reedy@deploy1001> Synchronized php-1.36.0-wmf.18/extensions/SecurePoll/includes/Crypt/GpgCrypt.php: Unbreak gpg encrypted polls T268583 (duration: 01m 06s)

Reedy closed this task as Resolved.Nov 24 2020, 12:30 AM
Reedy claimed this task.

Change 643107 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@master] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/643107

Change 642862 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@REL1_34] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642862

Change 642861 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@REL1_35] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642861

Change 642865 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/SecurePoll@wmf/1.36.0-wmf.16] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642865

Change 642865 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@wmf/1.36.0-wmf.16] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642865

Mentioned in SAL (#wikimedia-operations) [2020-11-24T00:42:48Z] <reedy@deploy1001> Synchronized php-1.36.0-wmf.16/extensions/SecurePoll/includes/Crypt/GpgCrypt.php: Unbreak gpg encrypted polls T268583 (duration: 01m 05s)

Change 642863 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@REL1_31] Use -o rather than --output when invoking gpg

https://gerrit.wikimedia.org/r/642863

Mz7 added a subscriber: Mz7.Nov 24 2020, 1:31 AM

Just want to drop a short comment to say thanks for the quick work in getting this fixed. :) We really appreciate it.