Page MenuHomePhabricator

[Legacy] Site logo in Vector links to current page instead of main page on mediawiki.org
Closed, ResolvedPublicPRODUCTION ERROR

Description

When visiting any page on mediawiki.org while using the vector skin, e.g. https://www.mediawiki.org/wiki/Download?useskinversion=1&useskin=vector the logo links back to the same page instead of the main page. Tested while both logged out and logged in.

Unable to reproduce this issue when using timeless or monobook, both link to the main page as expected.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Jan 13, 12:29 AM
Isarra added a subscriber: Isarra.

Specifically affects the 'old look'; the new one uses the correct link.

Change 655799 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/skins/Vector@master] Use {{link-mainpage}} in legacy sidebar same as new logo

https://gerrit.wikimedia.org/r/655799

Jdlrobson renamed this task from Site logo in Vector links to current page instead of main page on mediawiki.org to [Legacy] Site logo in Vector links to current page instead of main page on mediawiki.org.Wed, Jan 13, 2:00 AM
Jdlrobson assigned this task to Isarra.
Jdlrobson updated the task description. (Show Details)

Is there a hope of getting this merged and then backported today? Since it's a train blocker, technically it'd prevent promoting the train to group1 in the EU train window (which is in about two hours from now), but if the fix gets backported soon after that, I guess we could promote train to group1 and backport the change after that. Or not: I'm happy to defer to those who know better.

Change 655779 had a related patch set uploaded (by Phuedx; owner: Isarra):
[mediawiki/skins/Vector@wmf/1.36.0-wmf.26] Use {{link-mainpage}} in legacy sidebar same as new logo

https://gerrit.wikimedia.org/r/655779

phuedx added a subscriber: phuedx.Wed, Jan 13, 1:00 PM

@LarsWirzenius: The fix is merged and the above is the backport to the 1.36.0-wmf.26 branch. I'm happy to schedule it for the morning backport window at 7 PM UTC.

Change 655799 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Use {{link-mainpage}} in legacy sidebar same as new logo

https://gerrit.wikimedia.org/r/655799

@LarsWirzenius: The fix is merged and the above is the backport to the 1.36.0-wmf.26 branch. I'm happy to schedule it for the morning backport window at 7 PM UTC.

Thank you, that would be lovely.

Change 655779 merged by jenkins-bot:
[mediawiki/skins/Vector@wmf/1.36.0-wmf.26] Use {{link-mainpage}} in legacy sidebar same as new logo

https://gerrit.wikimedia.org/r/655779

Urbanecm triaged this task as Unbreak Now! priority.Wed, Jan 13, 2:09 PM
Urbanecm added a subscriber: Urbanecm.

This is marked as a blocker => triaging as UBN.

Mentioned in SAL (#wikimedia-operations) [2021-01-13T14:27:30Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.26/skins/Vector/includes/templates/legacy/Sidebar.mustache: 5a117ded68b5e0fc7f9b4a8a4513780e57eceefe: Use {{link-mainpage}} in legacy sidebar same as new logo (T271873) (duration: 01m 05s)

LarsWirzenius closed this task as Resolved.Wed, Jan 13, 2:31 PM

The fix has been backported, so closing task. Thank you to everyone involved.