Page MenuHomePhabricator

Special:Contributions triggers PHP Notice: Undefined index: start
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error Message
PHP Notice: Undefined index: start
(also: PHP Notice: Undefined index: end)
Impact

Presumably, paging doesn't work right on special:contributions under some circumstances

Notes

Seen 21 times within 10 minutes, all from wikidata. May be the same user hitting Special:Contributions some uncommon set of parameters (maybe by manipulating the URL?)

A brief look at the code led me to believe that the 'start' and 'end' fields in $this->opts may not be populated when $skip is set.

Details

Request ID
X-8cXk-QobwCAH86--JfMgAAARA
Request URL
https://www.wikidata.org/w/index.php?title=Special:Contributions&offset=20200115083227&target=2001%3AB07%3A6442%3A8903%3A0%3A0%3A0%3A0%2F64&namespace=all&tagfilter=&start=&end=

Event Timeline

daniel created this task.Jan 13 2021, 7:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 13 2021, 7:54 PM
daniel triaged this task as High priority.Jan 13 2021, 7:55 PM
daniel updated the task description. (Show Details)
daniel updated the task description. (Show Details)
Krinkle renamed this task from PHP Notice: Undefined index: start to PHP Notice: Undefined index: start (SpecialContributions.php).Jan 13 2021, 7:57 PM
Krinkle updated the task description. (Show Details)
Krinkle edited Stack Trace. (Show Details)
Krinkle changed Request URL from https://www.wikidata.org/w/index.php?title=Special:Contributions&offset=20200115083227&target=2001%3AB07%3A6442%3A8903%3A0%3A0%3A0%3A0%2F64&namespace=all&tagfilter=&start=&end= to https://www.wikidata.org/w/index.php?title=Special:Contributions&offset=….
daniel renamed this task from PHP Notice: Undefined index: start (SpecialContributions.php) to PHP Notice: Undefined index: start.Jan 13 2021, 7:58 PM
daniel changed Request URL from https://www.wikidata.org/w/index.php?title=Special:Contributions&offset=… to https://www.wikidata.org/w/index.php?title=Special:Contributions&offset=20200115083227&target=2001%3AB07%3A6442%3A8903%3A0%3A0%3A0%3A0%2F64&namespace=all&tagfilter=&start=&end=.
daniel updated the task description. (Show Details)

Change 656022 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/core@master] Guard against unset parameter index

https://gerrit.wikimedia.org/r/656022

Ammarpad claimed this task.Jan 14 2021, 6:50 AM
daniel renamed this task from PHP Notice: Undefined index: start to Special:Contributions triggers PHP Notice: Undefined index: start.Jan 14 2021, 2:45 PM

Change 656022 merged by jenkins-bot:
[mediawiki/core@master] SpecialContributions: Guard against unset parameter index

https://gerrit.wikimedia.org/r/656022

Ammarpad closed this task as Resolved.Jan 20 2021, 1:16 PM

Who is allowed to edit the mediawiki-new-errors board at https://logstash.wikimedia.org/app/dashboards#/view/0a9ecdc0-b6dc-11e8-9d8f-dbc23b470465?_g=h@8130aac&_a=h@f4fbfdc and remove this issue from the list of exclusions?

Who is allowed to edit the mediawiki-new-errors board at https://logstash.wikimedia.org/app/dashboards#/view/0a9ecdc0-b6dc-11e8-9d8f-dbc23b470465?_g=h@8130aac&_a=h@f4fbfdc and remove this issue from the list of exclusions?

I can. Done (and confirmed no hits since 22 Jan).