Page MenuHomePhabricator

FlaggedRevs does not give sysops the review right
Closed, ResolvedPublic

Description

While looking into T275017, I noticed that FlaggedRevs does not give sysops the review right. Unsure whether that's intentional, but IMO they should have that right, as it's an access level granted by sysops anyway.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSat, Feb 20, 11:04 PM

Change 665547 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/FlaggedRevs@master] Grant sysops review and unreviewed pages right by default

https://gerrit.wikimedia.org/r/665547

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptSat, Feb 20, 11:06 PM

Change 666013 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.31] Grant sysops review and unreviewed pages right by default

https://gerrit.wikimedia.org/r/666013

Change 665547 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@master] Grant sysops review and unreviewed pages right by default

https://gerrit.wikimedia.org/r/665547

Change 666013 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.31] Grant sysops review and unreviewed pages right by default

https://gerrit.wikimedia.org/r/666013

Mentioned in SAL (#wikimedia-operations) [2021-02-22T12:20:48Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.31/extensions/FlaggedRevs/extension.json: a4cd98e7a581fe18634da05ba04eaf8035023c26: Grant sysops review and unreviewed pages right by default (T275293) (duration: 00m 55s)

Urbanecm closed this task as Resolved.Mon, Feb 22, 12:21 PM

This should "fix" some cases when sysops are not able to set pending changes (which also require review right) on some wikis (that's why I backported it). Resolved.

Mentioned in SAL (#wikimedia-operations) [2021-02-22T13:36:19Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.31/extensions/FlaggedRevs/extension.json: a4cd98e7a581fe18634da05ba04eaf8035023c26: Grant sysops review and unreviewed pages right by default (apparently i forgot to rebase the first time, resync; T275293) (duration: 00m 57s)

MBH added a subscriber: MBH.Fri, Feb 26, 6:12 AM

4 admins of 80 in ruwiki deliberately refused review right, because review interface interferes with them. I think this change shouldn't be released, the system works with current settings more than 10 years and suits everyone.

4 admins of 80 in ruwiki deliberately refused review right, because review interface interferes with them. I think this change shouldn't be released, the system works with current settings more than 10 years and suits everyone.

If ru.wikipedia wishes to change this settings, they can fill a task. Note that due to T275334: Changing user groups from $wgExtensionFunctions no longer works reliably, it's not currently possible to change FR-introduced rights per wiki :/.

In all other cases, sysops already have rights they can grant to others (be it rollback, patroller at other wikis, eliminators, account creators, ...); it makes no sense for flaggedrevs to be an exception.

Base added a subscriber: Base.Sat, Feb 27, 3:03 PM

ukwiki also had a process for existing admins to agree to the new patrolling rules (which were completely different from new page patrol rules) back in June 2012 or so when FR was enabled. It is by design that some admins can potentially lose their editor flag and not be able to patrol. The communities should be notified about this change (perfectly the order should have been the opposite and the change done only after communities agreed). I will create a ticket for ukwiki to explicitly remove the permission from sysop later.