Page MenuHomePhabricator

automatic edit summary for categorizing pages
Open, LowestPublic

Description

It would be great to have a flag like the minor changes flag, except for
categorization work. Categorizing takes so many minor changes, it would be very
helpful if there was a way to filter them out.


Version: unspecified
Severity: enhancement

Details

Reference
bz931

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 7:04 PM
bzimport added a project: MediaWiki-Categories.
bzimport set Reference to bz931.
bzimport added a subscriber: Unknown Object (MLST).
JesseW created this task.Nov 23 2004, 10:53 AM

I think this would be an unnecessary complication; "minor" and the edit summary already
cover explaining that it's a trivial categorization edit and hence people uninterested can
skip over it easily enough.

It's the ability to ''automtically'' hide them that I would like. People use
various different ways of explaining that something is categorizing work ("cat",
"category", etc.), and sometimes they use the minor changes flag, but sometimes
they don't. If there was a seperate flag, it would be clearer, and unless you
worked on categorizing it wouldn't affect you at all.

rowan.collins wrote:

I think the problem is we could end up with a whole proliferation of "flags" of
this sort, and a) RecentChanges and page history displays would be cluttered up
with them and b) people would simply not bother using them. Indeed, if there are
already people failing to use the "minor edit" flag for minor categorization
edits, what makes you think they'll remember to tick one called "categorization
edit"? Or are you proposing (as others have) that this be an automatic test, in
which case what exactly would that test be?

Now I think about it, there can be such a thing as a major edit that only adds
or changes a category - it could be controversial, or it could even be
vandalism. So I'm not sure "categorization" would be a good category of edits to
seperate out.

artslave wrote:

How about automatic edit summary, the same way section headers are automatically
entered now:

Could the software detect if the ONLY thing a person enters is a [[Category:]] or a
{{template}} tag, and enter that tag text into the edit summary? Not only would it
make it quicker for those doing categorization work, it would make a consistent
format that is as easy to recognize on Recent Changes as a flag, and perhaps more
easy to filter either by us or by external bookmarklets and such.

Ok, let me try to be more specific. People currently start category-related
edit summaries with the word "cat". I would like a way to hide those items, or
show only them, as a way of dividing my watchlist. I can, and I will, write a
javascript bookmarklet to do this, but it would be more useful and easier for
other people to use if it was added to Mediawiki. That would not require any
more flags for people to pay attention to than they already do, and it would not
make controversial items any more likely to be missed; it would just add
technical support for an existing practice.

Regarding the idea of automatic insertion of the word "cat" if only category
items are entered, that's a good idea, also. It could also be implemented by a
bookmarklet, but people would have to click it everytime the saved a page(AFAIK,
now) as there is no way to automatically call a bookmarklet(if anyone knows how,
_*please*_ let me know).

shakes wrote:

Automatic edit summaries seems like a good idea, but it involves running a diff
between the previous and current version, extracting what's changed, trying to
work out what that is, and then changing the edit summary. It seems a lot of
work for a small benefit, especially since you'd be leaving the edit summary
blank and then just hoping your change met the criteria that caused it to
automatically fill in the sumary for you.

As I see it, the real problem is that categories are meta-data that shouldn't be
in the article text to start with ...

bugzillas+padREMOVETHISdu wrote:

It could be possible to implement this (if enough people find it useful & have
enough time...) by having an edit-link for categories just like the section-edit
links.

In the ideal world, all category tags would be lumped up somewhere at the end
and it might be easy to be able to edit just them. But in real life, there might
be articles with category tags in all places.

bugzillas+padREMOVETHISdu wrote:

Hey it just occured to me. If one is just going to add a category/template tag
(and isn't bothered about existing tags), one would just append whatever tags
one wants to the page. An ideal use of "action=edit&section=new".

Hence, I'd suggest an "append a tag" link to non-talk pages similar to the
"post-a-comment" link to talk-pages, with the edit summary prefilled with "/*
tag */" or something.

The editor could still choose whether to mark the edit as minor, of course.

hashar added a comment.Jul 6 2005, 2:53 PM

That will be trivially fixed the day we get interwikis and categories
links out of article. We can have two edit mode:
_ one for the article text
_ one for the metadatas

[Removing RESOLVED LATER as discussed in http://lists.wikimedia.org/pipermail/wikitech-l/2012-November/064240.html . Reopening and setting priority to "Lowest". For future reference, please use either RESOLVED WONTFIX (for issues that will not be fixed), or simply set lowest priority. Thanks a lot!]

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 17 2015, 7:12 PM

Currently, the getAutosummary function only has the old content and new content as inputs, and bases the summary off of the getChangeType results for the old and new contents. To define a new auto summary for this, it would need to also retrieve and parse the diff, or at least compare the old categories and new categories to see what changed. Potentially related: T3307