Page MenuHomePhabricator

Make LibUp pass on GrowthExperiments
Open, MediumPublic

Description

Now that LibUp is running again, we should make it pass for the GrowthExperiments repository. According to https://libraryupgrader2.wmcloud.org/r/mediawiki/extensions/GrowthExperiments?branch=main, the last couple of its runs were unsuccessful, with the following error:

Upgrading n:eslint-config-wikimedia from 0.25.1 -> 0.26.0
Upgrading n:grunt-banana-checker from 0.10.0 -> 0.11.1
Upgrading n:grunt-eslint from 24.0.1 -> 24.3.0
Upgrading n:grunt-stylelint from 0.18.0 -> 0.19.0
Upgrading n:stylelint-config-wikimedia from 0.14.0 -> 0.16.1
Upgrading n:vue from 3.2.37 -> 3.3.9
Upgrading n:@wikimedia/codex from 0.16.1 -> 1.3.2
$ /usr/bin/npm install
--- stderr ---
npm ERR! code ERESOLVE
npm ERR! ERESOLVE could not resolve
npm ERR! 
npm ERR! While resolving: GrowthExperiments@undefined
npm ERR! Found: @wikimedia/codex@0.16.1
npm ERR! node_modules/@wikimedia/codex
npm ERR!   dev @wikimedia/codex@"1.3.2" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! dev @wikimedia/codex@"1.3.2" from the root project
npm ERR! 
npm ERR! Conflicting peer dependency: vue@3.3.9
npm ERR! node_modules/vue
npm ERR!   peer vue@"3.3.9" from @wikimedia/codex@1.3.2
npm ERR!   node_modules/@wikimedia/codex
npm ERR!     dev @wikimedia/codex@"1.3.2" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! 
npm ERR! For a full report see:
npm ERR! /cache/_logs/2024-02-10T10_20_06_078Z-eresolve-report.txt

npm ERR! A complete log of this run can be found in:
npm ERR!     /cache/_logs/2024-02-10T10_20_06_078Z-debug-0.log
--- stdout ---

--- end ---

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm_WMF moved this task from Inbox to Backlog on the Growth-Team board.
KStoller-WMF lowered the priority of this task from High to Medium.Feb 29 2024, 5:21 PM
KStoller-WMF moved this task from Backlog to Up Next on the Growth-Team board.

Mabye the latest from stylelint-config-recommended-vue is also needed, which should support stylelint 15. But need to override the peer legacy part.

The tree for now:

# npm list stylelint
GrowthExperiments
+-- grunt-stylelint@0.18.0
| `-- stylelint@14.16.1
+-- stylelint-config-recommended-vue@1.4.0
| +-- stylelint-config-html@1.0.0
| | `-- stylelint@14.16.1 deduped
| +-- stylelint-config-recommended@9.0.0
| | `-- stylelint@14.16.1 deduped
| `-- stylelint@14.16.1 deduped
`-- stylelint-config-wikimedia@0.14.0
  +-- stylelint-no-unsupported-browser-features@6.1.0
  | `-- stylelint@14.16.1 deduped
  `-- stylelint@14.16.1 deduped

npm install stylelint-config-recommended-vue@1.5.0 stylelint-config-wikimedia@0.16.1 grunt-stylelint@0.19.0 --legacy-peer-deps

# npm list stylelint
+-- grunt-stylelint@0.19.0
| `-- stylelint@15.10.1
+-- stylelint-config-recommended-vue@1.5.0
| +-- stylelint-config-html@1.0.0
| | `-- stylelint@15.10.1 deduped
| +-- stylelint-config-recommended@13.0.0
| | `-- stylelint@15.10.1 deduped
| `-- stylelint@15.10.1 deduped
`-- stylelint-config-wikimedia@0.16.1
  +-- stylelint-no-unsupported-browser-features@6.1.0
  | `-- stylelint@15.10.1 deduped
  +-- stylelint-stylistic@0.4.3
  | `-- stylelint@15.10.1 deduped
  `-- stylelint@15.10.1 deduped

But that loose typescript

Missing: typescript@4.9.5 from lock file